{"answers":{"affected":"4 open source packages ship an affected version, including view_component. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24722 in the wild and no public exploit code.","fix":"Upgrade view_component to a fixed version for your release line: 2.31.2 or 2.49.1.","what":"CVE-2022-24722 is a high-severity cross-site scripting vulnerability in github view_component, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24722 and fix it if it is affected.\n\nWhat it is: CVE-2022-24722 is a high-severity cross-site scripting vulnerability in github view_component, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-24722 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- view_component (RubyGems): affected from 2.31.0; fixed in 2.31.2\n- view_component (RubyGems): affected from 2.31.0; fixed in 2.31.2\n- view_component (RubyGems): affected from 2.32.0; fixed in 2.49.1\n- view_component (RubyGems): affected from 2.32.0; fixed in 2.49.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24722/ (Markdown: https://insights.sbomify.com/CVE-2022-24722/index.md)","id":"CVE-2022-24722","markdown":"https://insights.sbomify.com/CVE-2022-24722/index.md","name":"CVE-2022-24722","record":{"aliases":["GHSA-cm9w-c4rj-r2cf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via unsanitized user input in view_component translations, affecting Ruby on Rails developers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"viewcomponent","vendor":"github"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in view_component","id":"CVE-2022-24722","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"Improper Input Validation in URI.js","id":"CVE-2022-24723"},"packages":[{"ecosystem":"RubyGems","fixed":["2.31.2"],"introduced":["2.31.0"],"last_affected":[],"package":"view_component","purl":null,"source":"GHSA-cm9w-c4rj-r2cf"},{"ecosystem":"RubyGems","fixed":["2.31.2"],"introduced":["2.31.0"],"last_affected":[],"package":"view_component","purl":"pkg:gem/view_component","source":"GHSA-cm9w-c4rj-r2cf"},{"ecosystem":"RubyGems","fixed":["2.49.1"],"introduced":["2.32.0"],"last_affected":[],"package":"view_component","purl":null,"source":"GHSA-cm9w-c4rj-r2cf"},{"ecosystem":"RubyGems","fixed":["2.49.1"],"introduced":["2.32.0"],"last_affected":[],"package":"view_component","purl":"pkg:gem/view_component","source":"GHSA-cm9w-c4rj-r2cf"}],"prev":{"headline":"Incorrect Authorization in org.cometd.oort","id":"CVE-2022-24721"},"products":["view_component"],"published":"2022-03-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["github"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via unsanitized user input in view_component translations, affecting Ruby on Rails developers.","url":"https://insights.sbomify.com/CVE-2022-24722/"}