# CVE-2022-24722: Cross-site Scripting in view_component

> Attackers can execute arbitrary scripts in victim browsers via unsanitized user input in view_component translations, affecting Ruby on Rails developers.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-cm9w-c4rj-r2cf

## What is CVE-2022-24722?

CVE-2022-24722 is a high-severity cross-site scripting vulnerability in github view_component, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24722?

4 open source packages ship an affected version, including view_component. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `view_component` | RubyGems | From 2.31.0 | 2.31.2 |
| `view_component` | RubyGems | From 2.31.0 | 2.31.2 |
| `view_component` | RubyGems | From 2.32.0 | 2.49.1 |
| `view_component` | RubyGems | From 2.32.0 | 2.49.1 |

Products: Github Viewcomponent.

## How do I fix CVE-2022-24722?

Upgrade view_component to a fixed version for your release line: 2.31.2 or 2.49.1.

## Is CVE-2022-24722 being exploited?

There is no known exploitation of CVE-2022-24722 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24722 and fix it if it is affected.

What it is: CVE-2022-24722 is a high-severity cross-site scripting vulnerability in github view_component, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24722 in the wild and no public exploit code.

Affected packages and fixed versions:
- view_component (RubyGems): affected from 2.31.0; fixed in 2.31.2
- view_component (RubyGems): affected from 2.31.0; fixed in 2.31.2
- view_component (RubyGems): affected from 2.32.0; fixed in 2.49.1
- view_component (RubyGems): affected from 2.32.0; fixed in 2.49.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24722/ (Markdown: https://insights.sbomify.com/CVE-2022-24722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24722
- OSV: https://osv.dev/vulnerability/CVE-2022-24722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24722/
Summaries are generated and may contain mistakes; the official description above is the record.
