{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24724 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2022-24724 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24724 and fix it if it is affected.\n\nWhat it is: CVE-2022-24724 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24724 exists.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24724/ (Markdown: https://insights.sbomify.com/CVE-2022-24724/index.md)","id":"CVE-2022-24724","markdown":"https://insights.sbomify.com/CVE-2022-24724/index.md","name":"CVE-2022-24724","record":{"aliases":["ALSA-2022:5597","DEBIAN-CVE-2022-24724","GHSA-mc3g-88wq-6f4x","RHSA-2022:5597","RLSA-2022:5597","UBUNTU-CVE-2022-24724"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Markdown parsing library","requires_auth":"low_privilege","summary":"Integer overflow in cmark-gfm table parsing allows heap corruption, potentially leading to remote code execution or information disclosure in applications rendering user-controlled markdown.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"cmark-gfm","vendor":"github"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"cmark-gfm is GitHub's extended version of the C reference implementation of CommonMark. Prior to versions 0.29.0.gfm.3 and 0.28.3.gfm.21, an integer overflow in cmark-gfm's table row parsing `table.c:row_from_string` may lead to heap memory corruption when parsing tables who's marker rows contain more than UINT16_MAX columns. The impact of this heap corruption ranges from Information Leak to Arbitrary Code Execution depending on how and where `cmark-gfm` is used. If `cmark-gfm` is used for rendering remote user controlled markdown, this vulnerability may lead to Remote Code Execution (RCE) in applications employing affected versions of the `cmark-gfm` library. This vulnerability has been patched in the following cmark-gfm versions 0.29.0.gfm.3 and 0.28.3.gfm.21. A workaround is available. The vulnerability exists in the table markdown extensions of cmark-gfm. Disabling the table extension will prevent this vulnerability from being triggered.","ecosystems":["AlmaLinux:8","Red Hat:enterprise_linux:8::crb","Rocky Linux:8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Integer overflow in table parsing extension leads to heap memory corruption","id":"CVE-2022-24724","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"integer_overflow","year":"2022"},"n_packages":5,"n_references":8,"next":{"headline":"Exposure of home directory through shescape on Unix with Bash","id":"CVE-2022-24725"},"packages":[{"ecosystem":"AlmaLinux:8","fixed":["2.0.6-6.el8_6"],"introduced":["0"],"last_affected":[],"package":"pandoc","purl":"pkg:rpm/almalinux/pandoc","source":"ALSA-2022:5597"},{"ecosystem":"AlmaLinux:8","fixed":["2.0.6-6.el8_6"],"introduced":["0"],"last_affected":[],"package":"pandoc-common","purl":"pkg:rpm/almalinux/pandoc-common","source":"ALSA-2022:5597"},{"ecosystem":"Red Hat:enterprise_linux:8::crb","fixed":["0:2.0.6-6.el8_6"],"introduced":["0"],"last_affected":[],"package":"pandoc","purl":"pkg:rpm/redhat/pandoc","source":"RHSA-2022:5597"},{"ecosystem":"Red Hat:enterprise_linux:8::crb","fixed":["0:2.0.6-6.el8_6"],"introduced":["0"],"last_affected":[],"package":"pandoc-common","purl":"pkg:rpm/redhat/pandoc-common","source":"RHSA-2022:5597"},{"ecosystem":"Rocky Linux:8","fixed":["0:2.0.6-6.el8_6"],"introduced":["0"],"last_affected":[],"package":"pandoc","purl":"pkg:rpm/rocky-linux/pandoc?distro=rocky-linux-8\u0026epoch=0","source":"RLSA-2022:5597"}],"prev":{"headline":"Improper Input Validation in URI.js","id":"CVE-2022-24723"},"products":["cmark-gfm"],"published":"2022-03-03","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["github"]},"summary":"Integer overflow in cmark-gfm table parsing allows heap corruption, potentially leading to remote code execution or information disclosure in applications rendering user-controlled markdown.","url":"https://insights.sbomify.com/CVE-2022-24724/"}