# CVE-2022-24724: Integer overflow in table parsing extension leads to heap memory corruption

> Integer overflow in cmark-gfm table parsing allows heap corruption, potentially leading to remote code execution or information disclosure in applications rendering user-controlled markdown.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** ALSA-2022:5597, DEBIAN-CVE-2022-24724, GHSA-mc3g-88wq-6f4x, RHSA-2022:5597, RLSA-2022:5597, UBUNTU-CVE-2022-24724

## What is CVE-2022-24724?

CVE-2022-24724 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

cmark-gfm is GitHub's extended version of the C reference implementation of CommonMark. Prior to versions 0.29.0.gfm.3 and 0.28.3.gfm.21, an integer overflow in cmark-gfm's table row parsing `table.c:row_from_string` may lead to heap memory corruption when parsing tables who's marker rows contain more than UINT16_MAX columns. The impact of this heap corruption ranges from Information Leak to Arbitrary Code Execution depending on how and where `cmark-gfm` is used. If `cmark-gfm` is used for rendering remote user controlled markdown, this vulnerability may lead to Remote Code Execution (RCE) in applications employing affected versions of the `cmark-gfm` library. This vulnerability has been patched in the following cmark-gfm versions 0.29.0.gfm.3 and 0.28.3.gfm.21. A workaround is available. The vulnerability exists in the table markdown extensions of cmark-gfm. Disabling the table extension will prevent this vulnerability from being triggered.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-24724?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pandoc` | AlmaLinux:8 | All versions | 2.0.6-6.el8_6 |
| `pandoc-common` | AlmaLinux:8 | All versions | 2.0.6-6.el8_6 |
| `pandoc` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.0.6-6.el8_6 |
| `pandoc-common` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.0.6-6.el8_6 |
| `pandoc` | Rocky Linux:8 | All versions | 0:2.0.6-6.el8_6 |

Products: Fedoraproject Fedora, Github Cmark-Gfm.

## How do I fix CVE-2022-24724?

Upgrade to a fixed version.

## Is CVE-2022-24724 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24724 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24724 and fix it if it is affected.

What it is: CVE-2022-24724 is a high-severity vulnerability in Fedoraproject Fedora, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24724 exists.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24724/ (Markdown: https://insights.sbomify.com/CVE-2022-24724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24724
- OSV: https://osv.dev/vulnerability/CVE-2022-24724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24724/
Summaries are generated and may contain mistakes; the official description above is the record.
