# CVE-2022-24728: Cross-site Scripting in CKEditor4


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24728, UBUNTU-CVE-2022-24728

## What is CVE-2022-24728?

CVE-2022-24728 is a medium-severity vulnerability in Drupal Drupal, published on 16 Mar 2022. 

### Official description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24728?

It affects 9 products.


Products: Ckeditor Ckeditor, Drupal Drupal, Fedoraproject Fedora, Oracle Application Express, Oracle Commerce Merchandising, Oracle Financial Services Analytical Applications Infrastructure, Oracle Financial Services Behavior Detection Platform, Oracle Financial Services Trade-Based Anti Money Laundering, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2022-24728?

Upgrade to a fixed version.

## Is CVE-2022-24728 being exploited?

There is no known exploitation of CVE-2022-24728 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24728 and fix it if it is affected.

What it is: CVE-2022-24728 is a medium-severity vulnerability in Drupal Drupal, published on 16 Mar 2022. 
Exploitation: There is no known exploitation of CVE-2022-24728 in the wild and no public exploit code.

Affected product: Drupal Drupal. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24728/ (Markdown: https://insights.sbomify.com/CVE-2022-24728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24728
- OSV: https://osv.dev/vulnerability/CVE-2022-24728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24728/
Summaries are generated and may contain mistakes; the official description above is the record.
