{"answers":{"affected":"2 open source packages ship an affected version, including github.com/foxcpp/maddy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24732 in the wild and no public exploit code.","fix":"Upgrade github.com/foxcpp/maddy to 0.5.4 or later.","what":"CVE-2022-24732 is a medium-severity authentication bypass vulnerability in foxcpp maddy, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24732 and fix it if it is affected.\n\nWhat it is: CVE-2022-24732 is a medium-severity authentication bypass vulnerability in foxcpp maddy, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24732 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.4\n- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24732/ (Markdown: https://insights.sbomify.com/CVE-2022-24732/index.md)","id":"CVE-2022-24732","markdown":"https://insights.sbomify.com/CVE-2022-24732/index.md","name":"CVE-2022-24732","record":{"aliases":["GHSA-6cp7-g972-w9m9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Maddy Mail Server","requires_auth":"low_privilege","summary":"Maddy Mail Server fails to enforce password or account expiry during PAM authentication, allowing access via expired credentials.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"maddy","vendor":"maddy_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"},{"id":"CWE-324","name":"Use of a Key Past its Expiration Date"}],"description":"Maddy Mail Server is an open source SMTP compatible email server. Versions of maddy prior to 0.5.4 do not implement password expiry or account expiry checking when authenticating using PAM. Users are advised to upgrade. Users unable to upgrade should manually remove expired accounts via existing filtering mechanisms.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Maddy Mail Server does not implement account expiry","id":"CVE-2022-24732","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Restriction of Rendered UI Layers or Frames in Sylius","id":"CVE-2022-24733"},"packages":[{"ecosystem":"Go","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":null,"source":"GHSA-6cp7-g972-w9m9"},{"ecosystem":"Go","fixed":["0.5.4"],"introduced":["0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GHSA-6cp7-g972-w9m9"}],"prev":{"headline":"Path traversal allows leaking out-of-bound files from Argo CD repo-server","id":"CVE-2022-24731"},"products":["maddy"],"published":"2022-03-09","related":[{"cvss_score":9.1,"headline":"Full authentication bypass if SASL authorization username is specified","id":"CVE-2023-27582","kev_date_added":null,"published":"2023-03-13"},{"cvss_score":8.2,"headline":"Maddy Mail Server: LDAP Filter Injection via Unsanitized Username","id":"CVE-2026-40193","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["foxcpp"]},"summary":"Maddy Mail Server fails to enforce password or account expiry during PAM authentication, allowing access via expired credentials.","url":"https://insights.sbomify.com/CVE-2022-24732/"}