# CVE-2022-24732: Maddy Mail Server does not implement account expiry

> Maddy Mail Server fails to enforce password or account expiry during PAM authentication, allowing access via expired credentials.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6cp7-g972-w9m9

## What is CVE-2022-24732?

CVE-2022-24732 is a medium-severity authentication bypass vulnerability in foxcpp maddy, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Maddy Mail Server is an open source SMTP compatible email server. Versions of maddy prior to 0.5.4 do not implement password expiry or account expiry checking when authenticating using PAM. Users are advised to upgrade. Users unable to upgrade should manually remove expired accounts via existing filtering mechanisms.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-324 (Use of a Key Past its Expiration Date)

## Which versions are affected by CVE-2022-24732?

2 open source packages ship an affected version, including github.com/foxcpp/maddy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/foxcpp/maddy` | Go | All versions | 0.5.4 |
| `github.com/foxcpp/maddy` | Go | All versions | 0.5.4 |

Products: Maddy Project Maddy.

## How do I fix CVE-2022-24732?

Upgrade github.com/foxcpp/maddy to 0.5.4 or later.

## Is CVE-2022-24732 being exploited?

There is no known exploitation of CVE-2022-24732 in the wild and no public exploit code.

## Other vulnerabilities in foxcpp maddy

- [CVE-2023-27582](https://insights.sbomify.com/CVE-2023-27582/): Full authentication bypass if SASL authorization username is specified (critical 9.1)
- [CVE-2026-40193](https://insights.sbomify.com/CVE-2026-40193/): Maddy Mail Server: LDAP Filter Injection via Unsanitized Username (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24732 and fix it if it is affected.

What it is: CVE-2022-24732 is a medium-severity authentication bypass vulnerability in foxcpp maddy, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24732 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.4
- github.com/foxcpp/maddy (Go): affected all versions; fixed in 0.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24732/ (Markdown: https://insights.sbomify.com/CVE-2022-24732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24732
- OSV: https://osv.dev/vulnerability/CVE-2022-24732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24732/
Summaries are generated and may contain mistakes; the official description above is the record.
