# CVE-2022-24733: Improper Restriction of Rendered UI Layers or Frames in Sylius

> Attackers can perform clickjacking attacks by loading the Sylius website in an iframe, potentially tricking users into unintended actions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4jp3-q2qm-9fmw

## What is CVE-2022-24733?

CVE-2022-24733 is a medium-severity vulnerability in Sylius, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sylius is an open source eCommerce platform. Prior to versions 1.9.10, 1.10.11, and 1.11.2, it is possible for a page controlled by an attacker to load the website within an iframe. This will enable a clickjacking attack, in which the attacker's page overlays the target application's interface with a different interface provided by the attacker. The issue is fixed in versions 1.9.10, 1.10.11, and 1.11.2. A workaround is available. Every response from app should have an X-Frame-Options header set to: ``sameorigin``. To achieve that, add a new `subscriber` in the app.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2022-24733?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | All versions | 1.9.10 |
| `sylius/sylius` | Packagist | All versions | 1.9.10 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |

Products: Sylius Sylius.

## How do I fix CVE-2022-24733?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.10, 1.10.11 or 1.11.2.

## Is CVE-2022-24733 being exploited?

There is no known exploitation of CVE-2022-24733 in the wild and no public exploit code.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24733 and fix it if it is affected.

What it is: CVE-2022-24733 is a medium-severity vulnerability in Sylius, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24733 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.10
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.10
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24733/ (Markdown: https://insights.sbomify.com/CVE-2022-24733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24733
- OSV: https://osv.dev/vulnerability/CVE-2022-24733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24733/
Summaries are generated and may contain mistakes; the official description above is the record.
