{"answers":{"affected":"1 open source package ship an affected version, including mybb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24734 exists.","fix":"Upgrade mybb to 1.8.30 or later.","what":"CVE-2022-24734 is a high-severity code injection vulnerability in Mybb Mybb, published on 9 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24734 and fix it if it is affected.\n\nWhat it is: CVE-2022-24734 is a high-severity code injection vulnerability in Mybb Mybb, published on 9 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24734 exists.\n\nAffected packages and fixed versions:\n- mybb (Bitnami): affected from 1.2.0; fixed in 1.8.30\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24734/ (Markdown: https://insights.sbomify.com/CVE-2022-24734/index.md)","id":"CVE-2022-24734","markdown":"https://insights.sbomify.com/CVE-2022-24734/index.md","name":"CVE-2022-24734","record":{"aliases":["BIT-mybb-2022-24734","GHSA-876v-gwgh-w57f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MyBB forum software","requires_auth":"high_privilege","summary":"Administrators with settings management permissions can inject PHP code via the Admin CP, leading to remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mybb","vendor":"mybb"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"MyBB is a free and open source forum software. In affected versions the Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type `php` with PHP code, executed on on _Change Settings_ pages. This results in a Remote Code Execution (RCE) vulnerability. The vulnerable module requires Admin CP access with the `Can manage settings?` permission. MyBB's Settings module, which allows administrators to add, edit, and delete non-default settings, stores setting data in an options code string ($options_code; mybb_settings.optionscode database column) that identifies the setting type and its options, separated by a new line character (\\n). In MyBB 1.2.0, support for setting type php was added, for which the remaining part of the options code is PHP code executed on Change Settings pages (reserved for plugins and internal use). MyBB 1.8.30 resolves this issue. There are no known workarounds.","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2022-03-09","github_poc":2,"max_poc_stars":48,"metasploit":1,"nuclei":0,"refs":[{"date":"2022-05-08T15:20:41Z","kind":"github_poc","ref":"https://github.com/Altelus1/CVE-2022-24734","stars":48,"title":"CVE-2022-24734 PoC"},{"date":"2022-05-15T19:18:32Z","kind":"github_poc","ref":"https://github.com/lavclash75/mybb-CVE-2022-24734","stars":1,"title":"MyBB 1.8.29 - Remote Code Execution"},{"date":"2022-03-09","kind":"metasploit","ref":"exploit/multi/http/mybb_rce_cve_2022_24734","stars":null,"title":"MyBB Admin Control Code Injection RCE"},{"date":"2022-05-11","kind":"exploitdb","ref":"50924","stars":null,"title":"MyBB 1.8.29 - MyBB 1.8.29 - Remote Code Execution (RCE) (Authenticated)"}],"tier":"weaponised"},"has_fix":true,"headline":"Remote code execution in mybb","id":"CVE-2022-24734","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mybb:mybb","products":["mybb:mybb"],"type":"code_injection","year":"2022"},"n_packages":1,"n_references":6,"next":{"headline":"Lua scripts can be manipulated to overcome ACL rules in Redis","id":"CVE-2022-24735"},"packages":[{"ecosystem":"Bitnami","fixed":["1.8.30"],"introduced":["1.2.0"],"last_affected":[],"package":"mybb","purl":"pkg:bitnami/mybb","source":"BIT-mybb-2022-24734"}],"prev":{"headline":"Improper Restriction of Rendered UI Layers or Frames in Sylius","id":"CVE-2022-24733"},"products":["mybb"],"published":"2022-03-09","related":[{"cvss_score":10,"headline":"myBB 1.6.4 Backdoor Arbitrary Command Execution","id":"CVE-2011-10018","kev_date_added":null,"published":"2025-08-13"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2015-2786","kev_date_added":null,"published":"2015-03-29"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2011-5133","kev_date_added":null,"published":"2012-08-30"},{"cvss_score":10,"headline":"SQL injection in n/a","id":"CVE-2006-0218","kev_date_added":null,"published":"2006-01-16"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2020-22612","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-16780","kev_date_added":null,"published":"2017-11-10"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2021-27890","kev_date_added":null,"published":"2021-03-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["mybb"]},"summary":"Administrators with settings management permissions can inject PHP code via the Admin CP, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2022-24734/"}