# CVE-2022-24734: Remote code execution in mybb

> Administrators with settings management permissions can inject PHP code via the Admin CP, leading to remote code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-mybb-2022-24734, GHSA-876v-gwgh-w57f

## What is CVE-2022-24734?

CVE-2022-24734 is a high-severity code injection vulnerability in Mybb Mybb, published on 9 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

MyBB is a free and open source forum software. In affected versions the Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type `php` with PHP code, executed on on _Change Settings_ pages. This results in a Remote Code Execution (RCE) vulnerability. The vulnerable module requires Admin CP access with the `Can manage settings?` permission. MyBB's Settings module, which allows administrators to add, edit, and delete non-default settings, stores setting data in an options code string ($options_code; mybb_settings.optionscode database column) that identifies the setting type and its options, separated by a new line character (\n). In MyBB 1.2.0, support for setting type php was added, for which the remaining part of the options code is PHP code executed on Change Settings pages (reserved for plugins and internal use). MyBB 1.8.30 resolves this issue. There are no known workarounds.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-24734?

1 open source package ship an affected version, including mybb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mybb` | Bitnami | From 1.2.0 | 1.8.30 |

Products: Mybb Mybb.

## How do I fix CVE-2022-24734?

Upgrade mybb to 1.8.30 or later.

## Is CVE-2022-24734 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24734 exists.

Public exploit code:

- CVE-2022-24734 PoC (github_poc): https://github.com/Altelus1/CVE-2022-24734
- MyBB 1.8.29 - Remote Code Execution (github_poc): https://github.com/lavclash75/mybb-CVE-2022-24734
- MyBB Admin Control Code Injection RCE (metasploit)
- MyBB 1.8.29 - MyBB 1.8.29 - Remote Code Execution (RCE) (Authenticated) (exploitdb)

## Other vulnerabilities in Mybb Mybb

- [CVE-2011-10018](https://insights.sbomify.com/CVE-2011-10018/): myBB 1.6.4 Backdoor Arbitrary Command Execution (critical 10.0)
- [CVE-2015-2786](https://insights.sbomify.com/CVE-2015-2786/): Information disclosure in n/a (critical 10.0)
- [CVE-2011-5133](https://insights.sbomify.com/CVE-2011-5133/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2006-0218](https://insights.sbomify.com/CVE-2006-0218/): SQL injection in n/a (critical 10.0)
- [CVE-2020-22612](https://insights.sbomify.com/CVE-2020-22612/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24734 and fix it if it is affected.

What it is: CVE-2022-24734 is a high-severity code injection vulnerability in Mybb Mybb, published on 9 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24734 exists.

Affected packages and fixed versions:
- mybb (Bitnami): affected from 1.2.0; fixed in 1.8.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24734/ (Markdown: https://insights.sbomify.com/CVE-2022-24734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24734
- OSV: https://osv.dev/vulnerability/CVE-2022-24734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24734/
Summaries are generated and may contain mistakes; the official description above is the record.
