{"answers":{"affected":"3 open source packages ship an affected version, including keydb, redis and valkey. It affects 5 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24735 exists.","fix":"Upgrade keydb to 6.2.7 or later.","what":"CVE-2022-24735 is a low-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24735 and fix it if it is affected.\n\nWhat it is: CVE-2022-24735 is a low-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24735 exists.\n\nAffected packages and fixed versions:\n- keydb (Bitnami): affected all versions; fixed in 6.2.7\n- redis (Bitnami): affected all versions; fixed in 6.2.7\n- valkey (Bitnami): affected all versions; fixed in 6.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24735/ (Markdown: https://insights.sbomify.com/CVE-2022-24735/index.md)","id":"CVE-2022-24735","markdown":"https://insights.sbomify.com/CVE-2022-24735/index.md","name":"CVE-2022-24735","record":{"aliases":["ALPINE-CVE-2022-24735","AZL-45285","AZL-71173","AZL-9598","BIT-keydb-2022-24735","BIT-redis-2022-24735","BIT-valkey-2022-24735","CLEANSTART-2026-TO47371","DEBIAN-CVE-2022-24735","GHSA-647m-2wmq-qmvq"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Redis database","requires_auth":"low_privilege","summary":"A less privileged user can inject Lua code to execute with higher privileges when a privileged user runs a script, requiring ACLs to be enabled.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"management_services_for_element_software","vendor":"netapp"},{"product":"management_services_for_netapp_hci","vendor":"netapp"},{"product":"communications_operations_monitor","vendor":"oracle"},{"product":"redis","vendor":"redis"}],"cvss":{"score":3.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Redis is an in-memory database that persists on disk. By exploiting weaknesses in the Lua script execution environment, an attacker with access to Redis prior to version 7.0.0 or 6.2.7 can inject Lua code that will execute with the (potentially higher) privileges of another Redis user. The Lua script execution environment in Redis provides some measures that prevent a script from creating side effects that persist and can affect the execution of the same, or different script, at a later time. Several weaknesses of these measures have been publicly known for a long time, but they had no security impact as the Redis security model did not endorse the concept of users or privileges. With the introduction of ACLs in Redis 6.0, these weaknesses can be exploited by a less privileged users to inject Lua code that will execute at a later time, when a privileged user executes a Lua script. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lua scripts can be manipulated to overcome ACL rules in Redis","id":"CVE-2022-24735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"code_injection","year":"2022"},"n_packages":3,"n_references":10,"next":{"headline":"A Malformed Lua script can crash Redis","id":"CVE-2022-24736"},"packages":[{"ecosystem":"Bitnami","fixed":["6.2.7"],"introduced":["0"],"last_affected":[],"package":"keydb","purl":"pkg:bitnami/keydb","source":"BIT-keydb-2022-24735"},{"ecosystem":"Bitnami","fixed":["6.2.7"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:bitnami/redis","source":"BIT-redis-2022-24735"},{"ecosystem":"Bitnami","fixed":["6.2.7"],"introduced":["0"],"last_affected":[],"package":"valkey","purl":"pkg:bitnami/valkey","source":"BIT-valkey-2022-24735"}],"prev":{"headline":"Remote code execution in mybb","id":"CVE-2022-24734"},"products":["redis"],"published":"2022-04-27","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["redis"]},"summary":"A less privileged user can inject Lua code to execute with higher privileges when a privileged user runs a script, requiring ACLs to be enabled.","url":"https://insights.sbomify.com/CVE-2022-24735/"}