# CVE-2022-24735: Lua scripts can be manipulated to overcome ACL rules in Redis

> A less privileged user can inject Lua code to execute with higher privileges when a privileged user runs a script, requiring ACLs to be enabled.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** ALPINE-CVE-2022-24735, AZL-45285, AZL-71173, AZL-9598, BIT-keydb-2022-24735, BIT-redis-2022-24735, BIT-valkey-2022-24735, CLEANSTART-2026-TO47371, DEBIAN-CVE-2022-24735, GHSA-647m-2wmq-qmvq

## What is CVE-2022-24735?

CVE-2022-24735 is a low-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Redis is an in-memory database that persists on disk. By exploiting weaknesses in the Lua script execution environment, an attacker with access to Redis prior to version 7.0.0 or 6.2.7 can inject Lua code that will execute with the (potentially higher) privileges of another Redis user. The Lua script execution environment in Redis provides some measures that prevent a script from creating side effects that persist and can affect the execution of the same, or different script, at a later time. Several weaknesses of these measures have been publicly known for a long time, but they had no security impact as the Redis security model did not endorse the concept of users or privileges. With the introduction of ACLs in Redis 6.0, these weaknesses can be exploited by a less privileged users to inject Lua code that will execute at a later time, when a privileged user executes a Lua script. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-24735?

3 open source packages ship an affected version, including keydb, redis and valkey. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keydb` | Bitnami | All versions | 6.2.7 |
| `redis` | Bitnami | All versions | 6.2.7 |
| `valkey` | Bitnami | All versions | 6.2.7 |

Products: Fedoraproject Fedora, Netapp Management Services for Element Software, Netapp Management Services for Netapp Hci, Oracle Communications Operations Monitor, Redis Redis.

## How do I fix CVE-2022-24735?

Upgrade keydb to 6.2.7 or later.

## Is CVE-2022-24735 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24735 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24735 and fix it if it is affected.

What it is: CVE-2022-24735 is a low-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24735 exists.

Affected packages and fixed versions:
- keydb (Bitnami): affected all versions; fixed in 6.2.7
- redis (Bitnami): affected all versions; fixed in 6.2.7
- valkey (Bitnami): affected all versions; fixed in 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24735/ (Markdown: https://insights.sbomify.com/CVE-2022-24735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24735
- OSV: https://osv.dev/vulnerability/CVE-2022-24735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24735/
Summaries are generated and may contain mistakes; the official description above is the record.
