# CVE-2022-24736: A Malformed Lua script can crash Redis

> An attacker can crash the Redis server by loading a specially crafted Lua script, causing a denial of service.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** ALPINE-CVE-2022-24736, AZL-45357, AZL-71176, AZL-9599, BIT-keydb-2022-24736, BIT-redis-2022-24736, BIT-valkey-2022-24736, CLEANSTART-2026-QU32085, DEBIAN-CVE-2022-24736, GHSA-3qpw-7686-5984, UBUNTU-CVE-2022-24736

## What is CVE-2022-24736?

CVE-2022-24736 is a low-severity vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an in-memory database that persists on disk. Prior to versions 6.2.7 and 7.0.0, an attacker attempting to load a specially crafted Lua script can cause NULL pointer dereference which will result with a crash of the redis-server process. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2022-24736?

3 open source packages ship an affected version, including keydb, redis and valkey. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keydb` | Bitnami | All versions | 6.2.7 |
| `redis` | Bitnami | All versions | 6.2.7 |
| `valkey` | Bitnami | All versions | 6.2.7 |

Products: Fedoraproject Fedora, Netapp Management Services for Element Software, Netapp Management Services for Netapp Hci, Oracle Communications Operations Monitor, Redis Redis.

## How do I fix CVE-2022-24736?

Upgrade keydb to 6.2.7 or later.

## Is CVE-2022-24736 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24736 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24736 and fix it if it is affected.

What it is: CVE-2022-24736 is a low-severity vulnerability in Fedoraproject Fedora, published on 27 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24736 exists.

Affected packages and fixed versions:
- keydb (Bitnami): affected all versions; fixed in 6.2.7
- redis (Bitnami): affected all versions; fixed in 6.2.7
- valkey (Bitnami): affected all versions; fixed in 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24736/ (Markdown: https://insights.sbomify.com/CVE-2022-24736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24736
- OSV: https://osv.dev/vulnerability/CVE-2022-24736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24736/
Summaries are generated and may contain mistakes; the official description above is the record.
