# CVE-2022-24737: Exposure of Sensitive Information to an Unauthorized Actor in httpie

> HTTPie leaks session cookies to third-party sites during redirects, exposing sensitive user data to unauthorized actors.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24737, GHSA-9w4w-cpc8-h2fq, MGASA-2023-0196, PYSEC-2022-34, UBUNTU-CVE-2022-24737

## What is CVE-2022-24737?

CVE-2022-24737 is a medium-severity vulnerability in Fedoraproject Fedora, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HTTPie is a command-line HTTP client. HTTPie has the practical concept of sessions, which help users to persistently store some of the state that belongs to the outgoing requests and incoming responses on the disk for further usage. Before 3.1.0, HTTPie didn‘t distinguish between cookies and hosts they belonged. This behavior resulted in the exposure of some cookies when there are redirects originating from the actual host to a third party website. Users are advised to upgrade. There are no known workarounds.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24737?

3 open source packages ship an affected version, including httpie. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpie` | PyPI | All versions | 3.1.0 |
| `httpie` | PyPI | All versions | 3.1.0 |
| `httpie` | PyPI | All versions | 3.1.0 |

Products: Fedoraproject Fedora, Httpie Httpie.

## How do I fix CVE-2022-24737?

Upgrade httpie to 3.1.0 or later.

## Is CVE-2022-24737 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24737 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24737 and fix it if it is affected.

What it is: CVE-2022-24737 is a medium-severity vulnerability in Fedoraproject Fedora, published on 7 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24737 exists.

Affected packages and fixed versions:
- httpie (PyPI): affected all versions; fixed in 3.1.0
- httpie (PyPI): affected all versions; fixed in 3.1.0
- httpie (PyPI): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24737/ (Markdown: https://insights.sbomify.com/CVE-2022-24737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24737
- OSV: https://osv.dev/vulnerability/CVE-2022-24737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24737/
Summaries are generated and may contain mistakes; the official description above is the record.
