# CVE-2022-24738: Account compromise in Evmos

> Attackers can drain unclaimed funds from user addresses by connecting a malicious chain that bypasses signature verification in Evmos.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-5jgq-x857-p8xw, GO-2022-0348

## What is CVE-2022-24738?

CVE-2022-24738 is a high-severity authentication bypass vulnerability in tharsis evmos, published on 7 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Evmos is the Ethereum Virtual Machine (EVM) Hub on the Cosmos Network. In versions of evmos prior to 2.0.1 attackers are able to drain unclaimed funds from user addresses. To do this an attacker must create a new chain which does not enforce signature verification and connects it to the target evmos instance. The attacker can use this joined chain to transfer unclaimed funds. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-24738?

4 open source packages ship an affected version, including github.com/tharsis/evmos and github.com/tharsis/evmos/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/tharsis/evmos` | Go | All versions | None |
| `github.com/tharsis/evmos` | Go | All versions | 2.0.1 |
| `github.com/tharsis/evmos` | Go | All versions | 2.0.1 |
| `github.com/tharsis/evmos/v2` | Go | All versions | 2.0.1 |

Products: Evmos Evmos.

## How do I fix CVE-2022-24738?

Upgrade github.com/tharsis/evmos to 2.0.1 or later.

## Is CVE-2022-24738 being exploited?

There is no known exploitation of CVE-2022-24738 in the wild and no public exploit code.

## Other vulnerabilities in tharsis evmos

- [CVE-2024-32644](https://insights.sbomify.com/CVE-2024-32644/): Evmos' transaction execution not accounting for all state transition after interaction with precompiles (critical 9.1)
- [CVE-2024-39696](https://insights.sbomify.com/CVE-2024-39696/): Evmos vulnerable to exploit of smart contract account and vesting (high 8.8)
- [CVE-2024-37153](https://insights.sbomify.com/CVE-2024-37153/): Evmos's contract balance not updating correctly after interchain transaction (high 7.5)
- [CVE-2024-37154](https://insights.sbomify.com/CVE-2024-37154/): Evmos allows unvested token delegations (medium 5.3)
- [CVE-2024-37158](https://insights.sbomify.com/CVE-2024-37158/): Evmos is missing precompile checks (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24738 and fix it if it is affected.

What it is: CVE-2022-24738 is a high-severity authentication bypass vulnerability in tharsis evmos, published on 7 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24738 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/tharsis/evmos (Go): affected all versions; no fix listed
- github.com/tharsis/evmos (Go): affected all versions; fixed in 2.0.1
- github.com/tharsis/evmos (Go): affected all versions; fixed in 2.0.1
- github.com/tharsis/evmos/v2 (Go): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24738/ (Markdown: https://insights.sbomify.com/CVE-2022-24738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24738
- OSV: https://osv.dev/vulnerability/CVE-2022-24738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24738/
Summaries are generated and may contain mistakes; the official description above is the record.
