# CVE-2022-24743: Insufficient Session Expiration in Sylius

> Attackers can reuse reset password tokens to change passwords and take over accounts due to insufficient session expiration in Sylius.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-mf3v-f2qq-pf9g

## What is CVE-2022-24743?

CVE-2022-24743 is a high-severity authentication bypass vulnerability in Sylius, published on 14 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sylius is an open source eCommerce platform. Prior to versions 1.10.11 and 1.11.2, the reset password token was not set to null after the password was changed. The same token could be used several times, which could result in leak of the existing token and unauthorized password change. The issue is fixed in versions 1.10.11 and 1.11.2. As a workaround, overwrite the `Sylius\Bundle\ApiBundle\CommandHandler\ResetPasswordHandler` class with code provided by the maintainers and register it in a container. More information about this workaround is available in the GitHub Security Advisory.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-24743?

4 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |

Products: Sylius Sylius.

## How do I fix CVE-2022-24743?

Upgrade sylius/sylius to a fixed version for your release line: 1.10.11 or 1.11.2.

## Is CVE-2022-24743 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24743 exists.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)
- [CVE-2026-31821](https://insights.sbomify.com/CVE-2026-31821/): Sylius is Missing Authorization in API v2 Add Item Endpoint (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24743 and fix it if it is affected.

What it is: CVE-2022-24743 is a high-severity authentication bypass vulnerability in Sylius, published on 14 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24743 exists.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24743/ (Markdown: https://insights.sbomify.com/CVE-2022-24743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24743
- OSV: https://osv.dev/vulnerability/CVE-2022-24743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24743/
Summaries are generated and may contain mistakes; the official description above is the record.
