CVE-2022-24744 Insufficient Session Expiration in shopware

Low 2.6 Published Updated

Attackers can maintain access to user accounts after password resets because active sessions are not invalidated, allowing unauthorized account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-24744?

CVE-2022-24744 is a low-severity authentication bypass vulnerability in Shopware Shopware, published on 9 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions user sessions are not logged out if the password is reset via password recovery. This issue has been resolved in version 6.4.8.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Weakness: CWE-613

Which versions are affected by CVE-2022-24744?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistAll versions6.4.8.1
shopware/core PackagistAll versions6.4.8.1
shopware/platform PackagistAll versions6.4.8.1
shopware/platform PackagistAll versions6.4.8.1

Products include Shopware Shopware.

How do I fix CVE-2022-24744?

Upgrade shopware/core to 6.4.8.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-24744 being exploited?

There is no known exploitation of CVE-2022-24744 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-w267-m9c4-8555.

Is CVE-2022-24744 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free