# CVE-2022-24744: Insufficient Session Expiration in shopware

> Attackers can maintain access to user accounts after password resets because active sessions are not invalidated, allowing unauthorized account takeover.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-w267-m9c4-8555

## What is CVE-2022-24744?

CVE-2022-24744 is a low-severity authentication bypass vulnerability in Shopware Shopware, published on 9 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions user sessions are not logged out if the password is reset via password recovery. This issue has been resolved in version 6.4.8.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-24744?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.8.1 |
| `shopware/core` | Packagist | All versions | 6.4.8.1 |
| `shopware/platform` | Packagist | All versions | 6.4.8.1 |
| `shopware/platform` | Packagist | All versions | 6.4.8.1 |

Products: Shopware Shopware.

## How do I fix CVE-2022-24744?

Upgrade shopware/core to 6.4.8.1 or later.

## Is CVE-2022-24744 being exploited?

There is no known exploitation of CVE-2022-24744 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24744 and fix it if it is affected.

What it is: CVE-2022-24744 is a low-severity authentication bypass vulnerability in Shopware Shopware, published on 9 Mar 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24744 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24744/ (Markdown: https://insights.sbomify.com/CVE-2022-24744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24744
- OSV: https://osv.dev/vulnerability/CVE-2022-24744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24744/
Summaries are generated and may contain mistakes; the official description above is the record.
