# CVE-2022-24746: HTML injection possibility in voucher code form

> Attackers can inject malicious HTML or scripts via the voucher code form in Shopware, potentially compromising user sessions or executing code.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-952p-fqcp-g8pc

## What is CVE-2022-24746?

CVE-2022-24746 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 9 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions it is possible to inject code via the voucher code form. This issue has been patched in version 6.4.8.1. There are no known workarounds for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24746?

6 open source packages ship an affected version, including shopware/core, shopware/platform and shopware/storefront. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.8.1 |
| `shopware/core` | Packagist | All versions | 6.4.8.1 |
| `shopware/platform` | Packagist | All versions | 6.4.8.1 |
| `shopware/platform` | Packagist | All versions | 6.4.8.1 |
| `shopware/storefront` | Packagist | All versions | 6.4.8.1 |
| `shopware/storefront` | Packagist | All versions | 6.4.8.1 |

Products: Shopware Shopware.

## How do I fix CVE-2022-24746?

Upgrade shopware/core to 6.4.8.1 or later.

## Is CVE-2022-24746 being exploited?

There is no known exploitation of CVE-2022-24746 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24746 and fix it if it is affected.

What it is: CVE-2022-24746 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 9 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24746 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/storefront (Packagist): affected all versions; fixed in 6.4.8.1
- shopware/storefront (Packagist): affected all versions; fixed in 6.4.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24746/ (Markdown: https://insights.sbomify.com/CVE-2022-24746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24746
- OSV: https://osv.dev/vulnerability/CVE-2022-24746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24746/
Summaries are generated and may contain mistakes; the official description above is the record.
