# CVE-2022-24747: HTTP caching is marking private HTTP headers as public

> Attackers can expose sensitive HTTP headers via intermediate caches if an HTTP cache is present, requiring an upgrade to Shopware.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6wrh-279j-6hvw

## What is CVE-2022-24747?

CVE-2022-24747 is a medium-severity vulnerability in Shopware Shopware, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. Affected versions of shopware do no properly set sensitive HTTP headers to be non-cacheable. If there is an HTTP cache between the server and client then headers may be exposed via HTTP caches. This issue has been resolved in version 6.4.8.2. There are no known workarounds.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24747?

6 open source packages ship an affected version, including shopware/core, shopware/platform and shopware/storefront. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.8.2 |
| `shopware/core` | Packagist | All versions | 6.4.8.2 |
| `shopware/platform` | Packagist | All versions | 6.4.8.2 |
| `shopware/platform` | Packagist | All versions | 6.4.8.2 |
| `shopware/storefront` | Packagist | All versions | 6.4.8.2 |
| `shopware/storefront` | Packagist | All versions | 6.4.8.2 |

Products: Shopware Shopware.

## How do I fix CVE-2022-24747?

Upgrade shopware/core to 6.4.8.2 or later.

## Is CVE-2022-24747 being exploited?

There is no known exploitation of CVE-2022-24747 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24747 and fix it if it is affected.

What it is: CVE-2022-24747 is a medium-severity vulnerability in Shopware Shopware, published on 9 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24747 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.2
- shopware/core (Packagist): affected all versions; fixed in 6.4.8.2
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.2
- shopware/platform (Packagist): affected all versions; fixed in 6.4.8.2
- shopware/storefront (Packagist): affected all versions; fixed in 6.4.8.2
- shopware/storefront (Packagist): affected all versions; fixed in 6.4.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24747/ (Markdown: https://insights.sbomify.com/CVE-2022-24747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24747
- OSV: https://osv.dev/vulnerability/CVE-2022-24747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24747/
Summaries are generated and may contain mistakes; the official description above is the record.
