# CVE-2022-24749: Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius

> Attackers can upload malicious SVG files to trigger XSS in Sylius admin and shop pages, potentially executing scripts in victim browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-4qrp-27r3-66fj

## What is CVE-2022-24749?

CVE-2022-24749 is a medium-severity cross-site scripting vulnerability in Sylius, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sylius is an open source eCommerce platform. In versions prior to 1.9.10, 1.10.11, and 1.11.2, it is possible to upload an SVG file containing cross-site scripting (XSS) code in the admin panel. In order to perform a XSS attack, the file itself has to be open in a new card or loaded outside of the IMG tag. The problem applies both to the files opened on the admin panel and shop pages. The issue is fixed in versions 1.9.10, 1.10.11, and 1.11.2. As a workaround, require a library that adds on-upload file sanitization and overwrite the service before writing the file to the filesystem. The GitHub Security Advisory contains more specific information about the workaround.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-24749?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | All versions | 1.9.10 |
| `sylius/sylius` | Packagist | All versions | 1.9.10 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.11 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.2 |

Products: Sylius Sylius.

## How do I fix CVE-2022-24749?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.10, 1.10.11 or 1.11.2.

## Is CVE-2022-24749 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24749 exists.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24749 and fix it if it is affected.

What it is: CVE-2022-24749 is a medium-severity cross-site scripting vulnerability in Sylius, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24749 exists.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.10
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.10
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.11
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24749/ (Markdown: https://insights.sbomify.com/CVE-2022-24749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24749
- OSV: https://osv.dev/vulnerability/CVE-2022-24749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24749/
Summaries are generated and may contain mistakes; the official description above is the record.
