CVE-2022-24750 Low privilege user is able to exploit the service and gain SYSTEM privileges in UltraVNC server

High 8.8 Published Updated

A local authenticated user can exploit the DSM plugin module in UltraVNC server to escalate privileges to SYSTEM.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-24750?

CVE-2022-24750 is a high-severity vulnerability in UltraVNC, published on 10 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

UltraVNC is a free and open source remote pc access software. A vulnerability has been found in versions prior to 1.3.8.0 in which the DSM plugin module, which allows a local authenticated user to achieve local privilege escalation (LPE) on a vulnerable system. The vulnerability has been fixed to allow loading of plugins from the installed directory. Affected users should upgrade their UltraVNC to 1.3.8.1. Users unable to upgrade should not install and run UltraVNC server as a service. It is advisable to create a scheduled task on a low privilege account to launch WinVNC.exe instead. There are no known workarounds if winvnc needs to be started as a service.

Weakness: CWE-269

Which versions are affected by CVE-2022-24750?

It affects 1 product.

Products include Uvnc Ultravnc.

How do I fix CVE-2022-24750?

No fix has been published for CVE-2022-24750 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-24750 being exploited?

There is no known exploitation of CVE-2022-24750 in the wild and no public exploit code.

Sources

Also known as GHSA-3mvp-cp5x-vj5g.

Is CVE-2022-24750 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free