{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24750 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-24750 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-24750 is a high-severity vulnerability in UltraVNC, published on 10 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24750 and fix it if it is affected.\n\nWhat it is: CVE-2022-24750 is a high-severity vulnerability in UltraVNC, published on 10 Mar 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24750 in the wild and no public exploit code.\n\nAffected product: UltraVNC. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24750/ (Markdown: https://insights.sbomify.com/CVE-2022-24750/index.md)","id":"CVE-2022-24750","markdown":"https://insights.sbomify.com/CVE-2022-24750/index.md","name":"CVE-2022-24750","record":{"aliases":["GHSA-3mvp-cp5x-vj5g"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"UltraVNC server","requires_auth":"low_privilege","summary":"A local authenticated user can exploit the DSM plugin module in UltraVNC server to escalate privileges to SYSTEM.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ultravnc","vendor":"uvnc"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"UltraVNC is a free and open source remote pc access software. A vulnerability has been found in versions prior to 1.3.8.0 in which the DSM plugin module, which allows a local authenticated user to achieve local privilege escalation (LPE) on a vulnerable system. The vulnerability has been fixed to allow loading of plugins from the installed directory. Affected users should upgrade their UltraVNC to 1.3.8.1. Users unable to upgrade should not install and run UltraVNC server as a service. It is advisable to create a scheduled task on a low privilege account to launch WinVNC.exe instead. There are no known workarounds if winvnc needs to be started as a service.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Low privilege user is able to exploit the service and gain SYSTEM privileges in UltraVNC server","id":"CVE-2022-24750","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Race condition in Zulip","id":"CVE-2022-24751"},"packages":[],"prev":{"headline":"Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius","id":"CVE-2022-24749"},"products":["UltraVNC"],"published":"2022-03-10","related":[{"cvss_score":9.8,"headline":"Memory corruption in UltraVNC","id":"CVE-2019-8264","kev_date_added":null,"published":"2019-03-09"},{"cvss_score":9.8,"headline":"Memory corruption in UltraVNC","id":"CVE-2019-8265","kev_date_added":null,"published":"2019-03-09"},{"cvss_score":9.8,"headline":"Memory corruption in UltraVNC","id":"CVE-2019-8266","kev_date_added":null,"published":"2019-03-09"},{"cvss_score":9.8,"headline":"Memory corruption in UltraVNC","id":"CVE-2019-8280","kev_date_added":null,"published":"2019-03-09"},{"cvss_score":9.8,"headline":"Memory corruption in UltraVNC","id":"CVE-2018-15361","kev_date_added":null,"published":"2019-03-05"},{"cvss_score":9.8,"headline":"Integer overflow in UltraVNC","id":"CVE-2019-8260","kev_date_added":null,"published":"2019-03-05"},{"cvss_score":9.8,"headline":"Integer overflow in UltraVNC","id":"CVE-2019-8261","kev_date_added":null,"published":"2019-03-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["ultravnc"]},"summary":"A local authenticated user can exploit the DSM plugin module in UltraVNC server to escalate privileges to SYSTEM.","url":"https://insights.sbomify.com/CVE-2022-24750/"}