# CVE-2022-24752: SQL Injection through sorting parameters in SyliusGridBundle

> Attackers can inject SQL via sorting parameters in SyliusGridBundle, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2xmm-g482-4439

## What is CVE-2022-24752?

CVE-2022-24752 is a critical SQL injection vulnerability in SyliusGridBundle, published on 15 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SyliusGridBundle is a package of generic data grids for Symfony applications. Prior to versions 1.10.1 and 1.11-rc2, values added at the end of query sorting were passed directly to the database. The maintainers do not know if this could lead to direct SQL injections but took steps to remediate the vulnerability. The issue is fixed in versions 1.10.1 and 1.11-rc2. As a workaround, overwrite the`Sylius\Component\Grid\Sorting\Sorter.php` class and register it in the container. More information about this workaround is available in the GitHub Security Advisory.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-24752?

2 open source packages ship an affected version, including sylius/grid-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/grid-bundle` | Packagist | All versions | 1.10.1 |
| `sylius/grid-bundle` | Packagist | All versions | 1.10.1 |

Products: Sylius Syliusgridbundle.

## How do I fix CVE-2022-24752?

Upgrade sylius/grid-bundle to 1.10.1 or later.

## Is CVE-2022-24752 being exploited?

There is no known exploitation of CVE-2022-24752 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24752 and fix it if it is affected.

What it is: CVE-2022-24752 is a critical SQL injection vulnerability in SyliusGridBundle, published on 15 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24752 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/grid-bundle (Packagist): affected all versions; fixed in 1.10.1
- sylius/grid-bundle (Packagist): affected all versions; fixed in 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24752/ (Markdown: https://insights.sbomify.com/CVE-2022-24752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24752
- OSV: https://osv.dev/vulnerability/CVE-2022-24752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24752/
Summaries are generated and may contain mistakes; the official description above is the record.
