{"answers":{"affected":"3 open source packages ship an affected version, including github.com/stripe/stripe-cli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24753 in the wild and no public exploit code.","fix":"Upgrade github.com/stripe/stripe-cli to 1.7.13 or later.","what":"CVE-2022-24753 is a high-severity command injection vulnerability in stripe-cli, published on 9 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24753 and fix it if it is affected.\n\nWhat it is: CVE-2022-24753 is a high-severity command injection vulnerability in stripe-cli, published on 9 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-24753 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/stripe/stripe-cli (Go): affected all versions; fixed in 1.7.13\n- github.com/stripe/stripe-cli (Go): affected all versions; fixed in 1.7.13\n- github.com/stripe/stripe-cli (Go): affected all versions; fixed in 1.7.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24753/ (Markdown: https://insights.sbomify.com/CVE-2022-24753/index.md)","id":"CVE-2022-24753","markdown":"https://insights.sbomify.com/CVE-2022-24753/index.md","name":"CVE-2022-24753","record":{"aliases":["GHSA-4cx6-fj7j-pjx9","GO-2022-0350"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Stripe CLI","requires_auth":"none","summary":"An attacker can execute arbitrary code on Windows by planting files in a directory where specific Stripe CLI commands are run.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"stripe_cli","vendor":"stripe"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Stripe CLI is a command-line tool for the Stripe eCommerce platform. A vulnerability in Stripe CLI exists on Windows when certain commands are run in a directory where an attacker has planted files. The commands are `stripe login`, `stripe config -e`, `stripe community`, and `stripe open`. MacOS and Linux are unaffected. An attacker who successfully exploits the vulnerability can run arbitrary code in the context of the current user. The update addresses the vulnerability by throwing an error in these situations before the code can run.Users are advised to upgrade to version 1.7.13. There are no known workarounds for this issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in Stripe CLI on windows","id":"CVE-2022-24753","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Buffer overflow in pjsip","id":"CVE-2022-24754"},"packages":[{"ecosystem":"Go","fixed":["1.7.13"],"introduced":["0"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":null,"source":"GHSA-4cx6-fj7j-pjx9"},{"ecosystem":"Go","fixed":["1.7.13"],"introduced":["0"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":"pkg:golang/github.com/stripe/stripe-cli","source":"GHSA-4cx6-fj7j-pjx9"},{"ecosystem":"Go","fixed":["1.7.13"],"introduced":["0"],"last_affected":[],"package":"github.com/stripe/stripe-cli","purl":"pkg:golang/github.com/stripe/stripe-cli","source":"GO-2022-0350"}],"prev":{"headline":"SQL Injection through sorting parameters in SyliusGridBundle","id":"CVE-2022-24752"},"products":["stripe-cli"],"published":"2022-03-09","related":[{"cvss_score":7.6,"headline":"stripe-cli Path Traversal vulnerability","id":"CVE-2024-45401","kev_date_added":null,"published":"2024-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["stripe"]},"summary":"An attacker can execute arbitrary code on Windows by planting files in a directory where specific Stripe CLI commands are run.","url":"https://insights.sbomify.com/CVE-2022-24753/"}