# CVE-2022-24757: Sensitive Auth & Cookie data stored in Jupyter server logs

> Attackers can steal sensitive authentication cookies from Jupyter Server logs during 5xx errors, leading to unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24757, GHSA-p737-p57g-4cpr, PYSEC-2022-179, UBUNTU-CVE-2022-24757

## What is CVE-2022-24757?

CVE-2022-24757 is a high-severity vulnerability in jupyter-server jupyter_server, published on 23 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications. Prior to version 1.15.4, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter Server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter Server version 1.15.4 contains a patch for this issue. There are currently no known workarounds.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-24757?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 1.15.4 |
| `jupyter-server` | PyPI | All versions | 1.15.4 |
| `jupyter-server` | PyPI | All versions | 1.15.4 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2022-24757?

Upgrade jupyter-server to 1.15.4 or later.

## Is CVE-2022-24757 being exploited?

There is no known exploitation of CVE-2022-24757 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24757 and fix it if it is affected.

What it is: CVE-2022-24757 is a high-severity vulnerability in jupyter-server jupyter_server, published on 23 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24757 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 1.15.4
- jupyter-server (PyPI): affected all versions; fixed in 1.15.4
- jupyter-server (PyPI): affected all versions; fixed in 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24757/ (Markdown: https://insights.sbomify.com/CVE-2022-24757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24757
- OSV: https://osv.dev/vulnerability/CVE-2022-24757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24757/
Summaries are generated and may contain mistakes; the official description above is the record.
