# CVE-2022-24758: Insertion of Sensitive Information into Log File affects Jupyter Notebook

> Attackers can steal sensitive authentication cookies from server logs triggered by 5xx errors, leading to unauthorized access to the Jupyter server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-jupyter-base-notebook-2022-24758, BIT-jupyter-notebook-2022-24758, CLEANSTART-2026-LA02184, DEBIAN-CVE-2022-24758, GHSA-m87f-39q9-6f55, PYSEC-2022-180, UBUNTU-CVE-2022-24758

## What is CVE-2022-24758?

CVE-2022-24758 is a high-severity vulnerability in jupyter notebook, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jupyter notebook is a web-based notebook environment for interactive computing. Prior to version 6.4.9, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter notebook version 6.4.x contains a patch for this issue. There are currently no known workarounds.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-24758?

5 open source packages ship an affected version, including jupyter-base-notebook, jupyter-notebook and notebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-base-notebook` | Bitnami | All versions | 6.4.10 |
| `jupyter-notebook` | Bitnami | All versions | 6.4.10 |
| `notebook` | PyPI | All versions | 6.4.10 |
| `notebook` | PyPI | All versions | 6.4.10 |
| `notebook` | PyPI | All versions | 6.4.10 |

Products: Jupyter Notebook.

## How do I fix CVE-2022-24758?

Upgrade jupyter-base-notebook to 6.4.10 or later.

## Is CVE-2022-24758 being exploited?

There is no known exploitation of CVE-2022-24758 in the wild and no public exploit code.

## Other vulnerabilities in jupyter notebook

- [CVE-2021-32798](https://insights.sbomify.com/CVE-2021-32798/): Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook (critical 10.0)
- [CVE-2018-8768](https://insights.sbomify.com/CVE-2018-8768/): Jupyter Notebook file bypasses sanitization, executes JavaScript (high 7.8)
- [CVE-2019-10856](https://insights.sbomify.com/CVE-2019-10856/): Jupyter Notebook open redirect vulnerability (medium 6.1)
- [CVE-2018-19351](https://insights.sbomify.com/CVE-2018-19351/): Jupyter Notebook XSS via untrusted notebooks (medium 6.1)
- [CVE-2018-19352](https://insights.sbomify.com/CVE-2018-19352/): Jupyter Notebook XSS via directory name (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24758 and fix it if it is affected.

What it is: CVE-2022-24758 is a high-severity vulnerability in jupyter notebook, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24758 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-base-notebook (Bitnami): affected all versions; fixed in 6.4.10
- jupyter-notebook (Bitnami): affected all versions; fixed in 6.4.10
- notebook (PyPI): affected all versions; fixed in 6.4.10
- notebook (PyPI): affected all versions; fixed in 6.4.10
- notebook (PyPI): affected all versions; fixed in 6.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24758/ (Markdown: https://insights.sbomify.com/CVE-2022-24758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24758
- OSV: https://osv.dev/vulnerability/CVE-2022-24758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24758/
Summaries are generated and may contain mistakes; the official description above is the record.
