CVE-2022-24759 Failure to validate signature during handshake in @chainsafe/libp2p-noise
Attackers can bypass signature validation in the libp2p noise handshake to impersonate peers and cause their ban.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24759?
CVE-2022-24759 is a high-severity vulnerability in ChainSafe js-libp2p-noise, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.
Weakness: CWE-347
Which versions are affected by CVE-2022-24759?
4 open source packages ship an affected version, including @chainsafe/libp2p-noise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@chainsafe/libp2p-noise npm | All versions | 4.1.2 |
@chainsafe/libp2p-noise npm | All versions | 4.1.2 |
@chainsafe/libp2p-noise npm | From 5.0.0 | 5.0.3 |
@chainsafe/libp2p-noise npm | From 5.0.0 | 5.0.3 |
Products include Chainsafe Js-Libp2p-Noise.
How do I fix CVE-2022-24759?
Upgrade @chainsafe/libp2p-noise to a fixed version for your release line: 4.1.2 or 5.0.3.
Is CVE-2022-24759 being exploited?
There is no known exploitation of CVE-2022-24759 in the wild and no public exploit code.
Sources
Also known as GHSA-j3ff-xp6c-6gcc.