{"answers":{"affected":"4 open source packages ship an affected version, including @chainsafe/libp2p-noise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24759 in the wild and no public exploit code.","fix":"Upgrade @chainsafe/libp2p-noise to a fixed version for your release line: 4.1.2 or 5.0.3.","what":"CVE-2022-24759 is a high-severity vulnerability in ChainSafe js-libp2p-noise, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24759 and fix it if it is affected.\n\nWhat it is: CVE-2022-24759 is a high-severity vulnerability in ChainSafe js-libp2p-noise, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24759 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @chainsafe/libp2p-noise (npm): affected all versions; fixed in 4.1.2\n- @chainsafe/libp2p-noise (npm): affected all versions; fixed in 4.1.2\n- @chainsafe/libp2p-noise (npm): affected from 5.0.0; fixed in 5.0.3\n- @chainsafe/libp2p-noise (npm): affected from 5.0.0; fixed in 5.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24759/ (Markdown: https://insights.sbomify.com/CVE-2022-24759/index.md)","id":"CVE-2022-24759","markdown":"https://insights.sbomify.com/CVE-2022-24759/index.md","name":"CVE-2022-24759","record":{"aliases":["GHSA-j3ff-xp6c-6gcc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","other"],"network_reachable":"yes","non_default_config":false,"product_category":"libp2p noise library","requires_auth":"low_privilege","summary":"Attackers can bypass signature validation in the libp2p noise handshake to impersonate peers and cause their ban.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"js-libp2p-noise","vendor":"chainsafe"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Failure to validate signature during handshake in @chainsafe/libp2p-noise","id":"CVE-2022-24759","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"Command Injection in Parse server","id":"CVE-2022-24760"},"packages":[{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"@chainsafe/libp2p-noise","purl":null,"source":"GHSA-j3ff-xp6c-6gcc"},{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["0"],"last_affected":[],"package":"@chainsafe/libp2p-noise","purl":"pkg:npm/%40chainsafe/libp2p-noise","source":"GHSA-j3ff-xp6c-6gcc"},{"ecosystem":"npm","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"@chainsafe/libp2p-noise","purl":null,"source":"GHSA-j3ff-xp6c-6gcc"},{"ecosystem":"npm","fixed":["5.0.3"],"introduced":["5.0.0"],"last_affected":[],"package":"@chainsafe/libp2p-noise","purl":"pkg:npm/%40chainsafe/libp2p-noise","source":"GHSA-j3ff-xp6c-6gcc"}],"prev":{"headline":"Insertion of Sensitive Information into Log File affects Jupyter Notebook","id":"CVE-2022-24758"},"products":["js-libp2p-noise"],"published":"2022-03-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["ChainSafe"]},"summary":"Attackers can bypass signature validation in the libp2p noise handshake to impersonate peers and cause their ban.","url":"https://insights.sbomify.com/CVE-2022-24759/"}