# CVE-2022-24759: Failure to validate signature during handshake in @chainsafe/libp2p-noise

> Attackers can bypass signature validation in the libp2p noise handshake to impersonate peers and cause their ban.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-j3ff-xp6c-6gcc

## What is CVE-2022-24759?

CVE-2022-24759 is a high-severity vulnerability in ChainSafe js-libp2p-noise, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2022-24759?

4 open source packages ship an affected version, including @chainsafe/libp2p-noise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@chainsafe/libp2p-noise` | npm | All versions | 4.1.2 |
| `@chainsafe/libp2p-noise` | npm | All versions | 4.1.2 |
| `@chainsafe/libp2p-noise` | npm | From 5.0.0 | 5.0.3 |
| `@chainsafe/libp2p-noise` | npm | From 5.0.0 | 5.0.3 |

Products: Chainsafe Js-Libp2p-Noise.

## How do I fix CVE-2022-24759?

Upgrade @chainsafe/libp2p-noise to a fixed version for your release line: 4.1.2 or 5.0.3.

## Is CVE-2022-24759 being exploited?

There is no known exploitation of CVE-2022-24759 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24759 and fix it if it is affected.

What it is: CVE-2022-24759 is a high-severity vulnerability in ChainSafe js-libp2p-noise, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24759 in the wild and no public exploit code.

Affected packages and fixed versions:
- @chainsafe/libp2p-noise (npm): affected all versions; fixed in 4.1.2
- @chainsafe/libp2p-noise (npm): affected all versions; fixed in 4.1.2
- @chainsafe/libp2p-noise (npm): affected from 5.0.0; fixed in 5.0.3
- @chainsafe/libp2p-noise (npm): affected from 5.0.0; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24759/ (Markdown: https://insights.sbomify.com/CVE-2022-24759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24759
- OSV: https://osv.dev/vulnerability/CVE-2022-24759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24759/
Summaries are generated and may contain mistakes; the official description above is the record.
