{"answers":{"affected":"3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24760 exists.","fix":"Upgrade parse-server to 4.10.7 or later.","what":"CVE-2022-24760 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24760 and fix it if it is affected.\n\nWhat it is: CVE-2022-24760 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24760 exists.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 4.10.7\n- parse-server (npm): affected all versions; fixed in 4.10.7\n- parse (Bitnami): affected all versions; fixed in 4.10.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24760/ (Markdown: https://insights.sbomify.com/CVE-2022-24760/index.md)","id":"CVE-2022-24760","markdown":"https://insights.sbomify.com/CVE-2022-24760/index.md","name":"CVE-2022-24760","record":{"aliases":["BIT-parse-2022-24760","GHSA-p6h4-93qp-jhcm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on Parse Server instances via prototype pollution in the database controller.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parse-server","vendor":"parseplatform"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":"2022-03-31","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-03-31T08:06:36Z","kind":"github_poc","ref":"https://github.com/tuo4n8/CVE-2022-24760","stars":1,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"Command Injection in Parse server","id":"CVE-2022-24760","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"parseplatform:parse-server","products":["parseplatform:parse-server"],"type":"code_injection","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"HTTP Request Smuggling in waitress","id":"CVE-2022-24761"},"packages":[{"ecosystem":"Bitnami","fixed":["4.10.7"],"introduced":["0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2022-24760"},{"ecosystem":"npm","fixed":["4.10.7"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-p6h4-93qp-jhcm"},{"ecosystem":"npm","fixed":["4.10.7"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-p6h4-93qp-jhcm"}],"prev":{"headline":"Failure to validate signature during handshake in @chainsafe/libp2p-noise","id":"CVE-2022-24759"},"products":["parse-server"],"published":"2022-03-11","related":[{"cvss_score":10,"headline":"Parse Server role escalation and CLP bypass via direct `_Join` table write","id":"CVE-2026-30966","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":10,"headline":"Parse Server literalizeRegexPart SQL Injection","id":"CVE-2024-27298","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":9.9,"headline":"Parse Server session token exfiltration via `redirectClassNameForKey` query parameter","id":"CVE-2026-30965","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution","id":"CVE-2023-36475","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396","kev_date_added":null,"published":"2022-11-10"},{"cvss_score":9.3,"headline":"Parse Server: Account takeover via operator injection in authentication data identifier","id":"CVE-2026-32248","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["parse-community"]},"summary":"Remote attackers can execute arbitrary code on Parse Server instances via prototype pollution in the database controller.","url":"https://insights.sbomify.com/CVE-2022-24760/"}