# CVE-2022-24760: Command Injection in Parse server

> Remote attackers can execute arbitrary code on Parse Server instances via prototype pollution in the database controller.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-parse-2022-24760, GHSA-p6h4-93qp-jhcm

## What is CVE-2022-24760?

CVE-2022-24760 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-24760?

3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.7 |
| `parse-server` | npm | All versions | 4.10.7 |
| `parse` | Bitnami | All versions | 4.10.7 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2022-24760?

Upgrade parse-server to 4.10.7 or later.

## Is CVE-2022-24760 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24760 exists.

Public exploit code:

- https://github.com/tuo4n8/CVE-2022-24760 (github_poc): https://github.com/tuo4n8/CVE-2022-24760

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)
- [CVE-2022-39396](https://insights.sbomify.com/CVE-2022-39396/): Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24760 and fix it if it is affected.

What it is: CVE-2022-24760 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24760 exists.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.7
- parse-server (npm): affected all versions; fixed in 4.10.7
- parse (Bitnami): affected all versions; fixed in 4.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24760/ (Markdown: https://insights.sbomify.com/CVE-2022-24760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24760
- OSV: https://osv.dev/vulnerability/CVE-2022-24760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24760/
Summaries are generated and may contain mistakes; the official description above is the record.
