CVE-2022-24761 HTTP Request Smuggling in waitress
HTTP request smuggling in Waitress allows attackers to bypass proxy security controls and potentially access sensitive data when deployed behind a non-strict proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24761?
CVE-2022-24761 is a high-severity vulnerability in Debian Debian Linux, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.
Weakness: CWE-444
Which versions are affected by CVE-2022-24761?
3 open source packages ship an affected version, including waitress. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
waitress PyPI | All versions | 2.1.1 |
waitress PyPI | All versions | 2.1.1 |
waitress PyPI | All versions | 2.1.1 |
Linux distribution packages (36)
python-waitress Red Hat:openstack:13::el7 | All versions | 0:1.4.4-2.el7ost |
python2-waitress Red Hat:openstack:13::el7 | All versions | 0:1.4.4-2.el7ost |
python-waitress Red Hat:openstack:16.1::el8 | All versions | 0:2.0.0-1.el8ost |
python3-waitress Red Hat:openstack:16.1::el8 | All versions | 0:2.0.0-1.el8ost |
python-waitress Red Hat:openstack:16.2::el8 | All versions | 0:2.0.0-1.el8ost |
python3-waitress Red Hat:openstack:16.2::el8 | All versions | 0:2.0.0-1.el8ost |
python-waitress SUSE:Enterprise Storage 6 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Enterprise Storage 7 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:HPE Helion OpenStack 8 | All versions | 1.4.3-3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server 15-LTSS | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Manager Proxy 4.1 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Manager Retail Branch Server 4.1 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:Manager Server 4.1 | All versions | 1.4.3-150000.3.6.1 |
python-waitress SUSE:OpenStack Cloud 8 | All versions | 1.4.3-3.6.1 |
python-waitress SUSE:OpenStack Cloud 9 | All versions | 1.4.3-3.6.1 |
python-waitress SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.4.3-3.6.1 |
python-waitress SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.4.3-3.6.1 |
python-waitress openSUSE:Leap 15.3 | All versions | 1.4.3-150000.3.6.1 |
python-waitress openSUSE:Leap 15.4 | All versions | 1.4.3-150000.3.6.1 |
Products include Agendaless Waitress, Debian Debian Linux.
How do I fix CVE-2022-24761?
Upgrade waitress to 2.1.1 or later.
Is CVE-2022-24761 being exploited?
There is no known exploitation of CVE-2022-24761 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
- CVE-2024-49768 Waitress has request processing race condition in HTTP pipelining with invalid first request
- CVE-2024-49769 Waitress has a denial of service leading to high CPU usage/resource exhaustion
- CVE-2019-16792 HTTP Request Smuggling: Content-Length Sent Twice in Waitress
- CVE-2019-16789 HTTP Request Smuggling in Waitress: Invalid whitespace characters in headers
- CVE-2019-16785 HTTP Request Smuggling: LF vs CRLF handling in Waitress
Sources
Also known as AZL-43984, AZL-45060, DEBIAN-CVE-2022-24761, DSA-5138-1, GHSA-4f7p-27jc-3c36, MGASA-2022-0182 and 11 more.