# CVE-2022-24762: Exposure of Sensitive Information to an Unauthorized Actor in sysend.js

> Attackers can intercept cross-origin communications in sysend.js, exposing sensitive data to unauthorized actors.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-4vvg-x86p-mvqc

## What is CVE-2022-24762?

CVE-2022-24762 is a medium-severity vulnerability in jcubic sysend.js, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

sysend.js is a library that allows a user to send messages between pages that are open in the same browser. Users that use cross-origin communication may have their communications intercepted. Impact is limited by the communication occurring in the same browser. This issue has been patched in sysend.js version 1.10.0. The only currently known workaround is to avoid sending communications that a user does not want to have intercepted via sysend messages.

Weakness: CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24762?

2 open source packages ship an affected version, including sysend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sysend` | npm | All versions | 1.10.0 |
| `sysend` | npm | All versions | 1.10.0 |

Products: Sysend.js Project Sysend.js.

## How do I fix CVE-2022-24762?

Upgrade sysend to 1.10.0 or later.

## Is CVE-2022-24762 being exploited?

There is no known exploitation of CVE-2022-24762 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24762 and fix it if it is affected.

What it is: CVE-2022-24762 is a medium-severity vulnerability in jcubic sysend.js, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24762 in the wild and no public exploit code.

Affected packages and fixed versions:
- sysend (npm): affected all versions; fixed in 1.10.0
- sysend (npm): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24762/ (Markdown: https://insights.sbomify.com/CVE-2022-24762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24762
- OSV: https://osv.dev/vulnerability/CVE-2022-24762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24762/
Summaries are generated and may contain mistakes; the official description above is the record.
