CVE-2022-24766 Insufficient Protection against HTTP Request Smuggling in mitmproxy

Critical 9.8 Published Updated

Attackers can smuggle HTTP requests through mitmproxy, bypassing custom access controls and sanitization implemented in event hooks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24766?

CVE-2022-24766 is a critical vulnerability in mitmproxy, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While mitmproxy would only see one request, the target server would see multiple requests. A smuggled request is still captured as part of another request's body, but it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless mitmproxy is used to protect an HTTP/1 service, no action is required. The vulnerability has been fixed in mitmproxy 8.0.0 and above. There are currently no known workarounds.

Weakness: CWE-444

Which versions are affected by CVE-2022-24766?

3 open source packages ship an affected version, including mitmproxy. It affects 1 product.

PackageAffectedFixed in
mitmproxy PyPIAll versions8.0.0
mitmproxy PyPIAll versions8.0.0
mitmproxy PyPIAll versions8.0.0

Products include Mitmproxy Mitmproxy.

How do I fix CVE-2022-24766?

Upgrade mitmproxy to 8.0.0 or later.

Is CVE-2022-24766 being exploited?

There is no known exploitation of CVE-2022-24766 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2022-24766, GHSA-gcx2-gvj7-pxv3, PYSEC-2022-170, UBUNTU-CVE-2022-24766, openSUSE-SU-2024:11956-1.

Is CVE-2022-24766 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free