CVE-2022-24769 Default inheritable capabilities for linux container should be empty

Medium 5.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-24769?

CVE-2022-24769 is a medium-severity vulnerability in Debian Debian Linux, published on 24 Mar 2022.

Official description

Moby is an open-source project created by Docker to enable and accelerate software containerization. A bug was found in Moby (Docker Engine) prior to version 20.10.14 where containers were incorrectly started with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during `execve(2)`. Normally, when executable programs have specified permitted file capabilities, otherwise unprivileged users and processes can execute those programs and gain the specified file capabilities up to the bounding set. Due to this bug, containers which included executable programs with inheritable file capabilities allowed otherwise unprivileged users and processes to additionally gain these inheritable file capabilities up to the container's bounding set. Containers which use Linux users and groups to perform privilege separation inside the container are most directly impacted. This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set. This bug has been fixed in Moby (Docker Engine) 20.10.14. Running containers should be stopped, deleted, and recreated for the inheritable capabilities to be reset. This fix changes Moby (Docker Engine) behavior such that containers are started with a more typical Linux environment. As a workaround, the entry point of a container can be modified to use a utility like `capsh(1)` to drop inheritable capabilities prior to the primary process starting.

Weakness: CWE-732

Which versions are affected by CVE-2022-24769?

6 open source packages ship an affected version, including github.com/docker/docker and github.com/moby/moby. It affects 4 products.

PackageAffectedFixed in
github.com/docker/docker GoAll versions20.10.14
github.com/docker/docker GoAll versions20.10.14
github.com/docker/docker GoAll versions20.10.14+incompatible
github.com/moby/moby GoAll versions20.10.14
github.com/moby/moby GoAll versions20.10.14
github.com/moby/moby GoAll versions20.10.14+incompatible
Linux distribution packages (2)
containerd openSUSE:TumbleweedAll versions1.5.11-1.1
docker openSUSE:TumbleweedAll versions20.10.14_ce-1.1

Products include Debian Debian Linux, Fedoraproject Fedora, Linuxfoundation Runc, Mobyproject Moby.

How do I fix CVE-2022-24769?

Upgrade github.com/docker/docker to a fixed version for your release line: 20.10.14 or 20.10.14+incompatible.

Is CVE-2022-24769 being exploited?

There is no known exploitation of CVE-2022-24769 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as AZL-9698, CLEANSTART-2025-DA74849, CLEANSTART-2026-LD65772, DEBIAN-CVE-2022-24769, GHSA-2mm7-x5h6-5pvq, GO-2022-0390 and 6 more.

Is CVE-2022-24769 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free