# CVE-2022-24774: Improper Input Validation leading to Path Traversal in CycloneDX BOM Repository Server

> Attackers can create or delete arbitrary directories via path traversal in CycloneDX BOM Repository Server when POST and DELETE methods are enabled.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6c74-9588-wq9j

## What is CVE-2022-24774?

CVE-2022-24774 is a high-severity path traversal vulnerability in cyclonedx-bom-repo-server, published on 22 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CycloneDX BOM Repository Server is a bill of materials (BOM) repository server for distributing CycloneDX BOMs. CycloneDX BOM Repository Server before version 2.0.1 has an improper input validation vulnerability leading to path traversal. A malicious user may potentially exploit this vulnerability to create arbitrary directories or a denial of service by deleting arbitrary directories. The vulnerability is resolved in version 2.0.1. The vulnerability is not exploitable with the default configuration with the post and delete methods disabled. This can be configured by modifying the `appsettings.json` file, or alternatively, setting the environment variables `ALLOWEDMETHODS__POST` and `ALLOWEDMETHODS__DELETE` to `false`.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-35 (Path Traversal: '.../...//'), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24774?

It affects 1 product.


Products: Cyclonedx Bill of Materials Repository Server.

## How do I fix CVE-2022-24774?

No fix has been published for CVE-2022-24774 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-24774 being exploited?

There is no known exploitation of CVE-2022-24774 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24774 and fix it if it is affected.

What it is: CVE-2022-24774 is a high-severity path traversal vulnerability in cyclonedx-bom-repo-server, published on 22 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24774 in the wild and no public exploit code.

Affected product: cyclonedx-bom-repo-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24774/ (Markdown: https://insights.sbomify.com/CVE-2022-24774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24774
- OSV: https://osv.dev/vulnerability/CVE-2022-24774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24774/
Summaries are generated and may contain mistakes; the official description above is the record.
