{"answers":{"affected":"6 open source packages ship an affected version, including drupal, drupal/core and guzzlehttp/psr7. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-24775 in the wild and no public exploit code.","fix":"Upgrade drupal to a fixed version for your release line: 9.2.16 or 9.3.9.","what":"CVE-2022-24775 is a high-severity vulnerability in Drupal Drupal, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24775 and fix it if it is affected.\n\nWhat it is: CVE-2022-24775 is a high-severity vulnerability in Drupal Drupal, published on 21 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24775 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal (Bitnami): affected from 8.0.0; fixed in 9.2.16, 9.3.9\n- drupal/core (Packagist): affected from 8.0.0; fixed in 9.2.16, 9.3.9\n- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 1.8.4\n- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 1.8.4\n- guzzlehttp/psr7 (Packagist): affected from 2.0.0; fixed in 2.1.1\n- guzzlehttp/psr7 (Packagist): affected from 2.0.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24775/ (Markdown: https://insights.sbomify.com/CVE-2022-24775/index.md)","id":"CVE-2022-24775","markdown":"https://insights.sbomify.com/CVE-2022-24775/index.md","name":"CVE-2022-24775","record":{"aliases":["BIT-drupal-2022-24775","DEBIAN-CVE-2022-24775","DRUPAL-CORE-2022-006","GHSA-q7rv-6hp3-vh96","UBUNTU-CVE-2022-24775"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP message library","requires_auth":"none","summary":"Attackers can inject newlines into HTTP headers via improper parsing, potentially bypassing security controls or modifying data in applications using this library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"drupal","vendor":"drupal"},{"product":"psr-7","vendor":"guzzlephp"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in guzzlehttp/psr7","id":"CVE-2022-24775","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"drupal:drupal","products":["drupal:drupal"],"type":"other","year":"2022"},"n_packages":6,"n_references":4,"next":{"headline":"Open Redirect in Flask-AppBuilder","id":"CVE-2022-24776"},"packages":[{"ecosystem":"Bitnami","fixed":["9.2.16","9.3.9"],"introduced":["8.0.0","9.3.0"],"last_affected":[],"package":"drupal","purl":"pkg:bitnami/drupal","source":"BIT-drupal-2022-24775"},{"ecosystem":"Packagist","fixed":["9.2.16","9.3.9"],"introduced":["8.0.0","9.3.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"DRUPAL-CORE-2022-006"},{"ecosystem":"Packagist","fixed":["1.8.4"],"introduced":["0"],"last_affected":[],"package":"guzzlehttp/psr7","purl":null,"source":"GHSA-q7rv-6hp3-vh96"},{"ecosystem":"Packagist","fixed":["1.8.4"],"introduced":["0"],"last_affected":[],"package":"guzzlehttp/psr7","purl":"pkg:composer/guzzlehttp/psr7","source":"GHSA-q7rv-6hp3-vh96"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"guzzlehttp/psr7","purl":null,"source":"GHSA-q7rv-6hp3-vh96"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"guzzlehttp/psr7","purl":"pkg:composer/guzzlehttp/psr7","source":"GHSA-q7rv-6hp3-vh96"}],"prev":{"headline":"Improper Input Validation leading to Path Traversal in CycloneDX BOM Repository Server","id":"CVE-2022-24774"},"products":["psr7"],"published":"2022-03-21","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["guzzle"]},"summary":"Attackers can inject newlines into HTTP headers via improper parsing, potentially bypassing security controls or modifying data in applications using this library.","url":"https://insights.sbomify.com/CVE-2022-24775/"}