# CVE-2022-24776: Open Redirect in Flask-AppBuilder

> An open redirect vulnerability in Flask-AppBuilder's database authentication login page allows attackers to redirect users to malicious sites.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2ccw-7px8-vmpf, PYSEC-2026-635

## What is CVE-2022-24776?

CVE-2022-24776 is a medium-severity vulnerability in dpgaspar Flask-AppBuilder, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flask-AppBuilder is an application development framework, built on top of the Flask web framework. Flask-AppBuilder contains an open redirect vulnerability when using database authentication login page on versions below 3.4.5. This issue is fixed in version 3.4.5. There are currently no known workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-24776?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 3.4.5 |
| `flask-appbuilder` | PyPI | All versions | 3.4.5 |
| `Flask-AppBuilder` | PyPI | All versions | 3.4.5 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2022-24776?

Upgrade flask-appbuilder to 3.4.5 or later.

## Is CVE-2022-24776 being exploited?

There is no known exploitation of CVE-2022-24776 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24776 and fix it if it is affected.

What it is: CVE-2022-24776 is a medium-severity vulnerability in dpgaspar Flask-AppBuilder, published on 24 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24776 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 3.4.5
- flask-appbuilder (PyPI): affected all versions; fixed in 3.4.5
- Flask-AppBuilder (PyPI): affected all versions; fixed in 3.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24776/ (Markdown: https://insights.sbomify.com/CVE-2022-24776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24776
- OSV: https://osv.dev/vulnerability/CVE-2022-24776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24776/
Summaries are generated and may contain mistakes; the official description above is the record.
