# CVE-2022-24777: Denial of Service via reachable assertion in grpc-swift

> A reachable assertion in grpc-swift allows attackers to crash the server via crafted GOAWAY frames, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-r6ww-5963-7r95

## What is CVE-2022-24777?

CVE-2022-24777 is a high-severity denial of service vulnerability in grpc-swift, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

grpc-swift is the Swift language implementation of gRPC, a remote procedure call (RPC) framework. Prior to version 1.7.2, a grpc-swift server is vulnerable to a denial of service attack via a reachable assertion. This is due to incorrect logic when handling GOAWAY frames. The attack is low-effort: it takes very little resources to construct and send the required sequence of frames. The impact on availability is high as the server will crash, dropping all in flight connections and requests. This issue is fixed in version 1.7.2. There are currently no known workarounds.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2022-24777?

2 open source packages ship an affected version, including github.com/grpc/grpc-swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grpc/grpc-swift` | SwiftURL | All versions | 1.7.2 |
| `github.com/grpc/grpc-swift` | SwiftURL | All versions | 1.7.2 |

Products: Linuxfoundation Grpc Swift.

## How do I fix CVE-2022-24777?

Upgrade github.com/grpc/grpc-swift to 1.7.2 or later.

## Is CVE-2022-24777 being exploited?

There is no known exploitation of CVE-2022-24777 in the wild and no public exploit code.

## Other vulnerabilities in grpc-swift

- [CVE-2021-36153](https://insights.sbomify.com/CVE-2021-36153/): Incomplete Internal State Distinction in GRPCWebToHTTP2ServerCodec (high 7.5)
- [CVE-2021-36154](https://insights.sbomify.com/CVE-2021-36154/): Uncontrolled Recursion in HTTP2ToRawGRPCServerCodec (high 7.5)
- [CVE-2021-36155](https://insights.sbomify.com/CVE-2021-36155/): Uncontrolled Resource Consumption in LengthPrefixedMessageReader (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24777 and fix it if it is affected.

What it is: CVE-2022-24777 is a high-severity denial of service vulnerability in grpc-swift, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24777 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grpc/grpc-swift (SwiftURL): affected all versions; fixed in 1.7.2
- github.com/grpc/grpc-swift (SwiftURL): affected all versions; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24777/ (Markdown: https://insights.sbomify.com/CVE-2022-24777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24777
- OSV: https://osv.dev/vulnerability/CVE-2022-24777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24777/
Summaries are generated and may contain mistakes; the official description above is the record.
