# CVE-2022-24778: Incorrect Authorization in imgcrypt

> Attackers can bypass authorization checks to run previously decrypted encrypted container images on systems with multi-architecture manifests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-8v99-48m9-c8pm, GO-2021-0412, UBUNTU-CVE-2022-24778

## What is CVE-2022-24778?

CVE-2022-24778 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The imgcrypt library provides API exensions for containerd to support encrypted container images and implements the ctd-decoder command line tool for use by containerd to decrypt encrypted container images. The imgcrypt function `CheckAuthorization` is supposed to check whether the current used is authorized to access an encrypted image and prevent the user from running an image that another user previously decrypted on the same system. In versions prior to 1.1.4, a failure occurs when an image with a ManifestList is used and the architecture of the local host is not the first one in the ManifestList. Only the first architecture in the list was tested, which may not have its layers available locally since it could not be run on the host architecture. Therefore, the verdict on unavailable layers was that the image could be run anticipating that image run failure would occur later due to the layers not being available. However, this verdict to allow the image to run enabled other architectures in the ManifestList to run an image without providing keys if that image had previously been decrypted. A patch has been applied to imgcrypt 1.1.4. Workarounds may include usage of different namespaces for each remote user.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-24778?

3 open source packages ship an affected version, including github.com/containerd/imgcrypt. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/imgcrypt` | Go | All versions | 1.1.4 |
| `github.com/containerd/imgcrypt` | Go | All versions | 1.1.4 |
| `github.com/containerd/imgcrypt` | Go | All versions | 1.1.4 |

Products: Fedoraproject Fedora, Linuxfoundation Imgcrypt.

## How do I fix CVE-2022-24778?

Upgrade github.com/containerd/imgcrypt to 1.1.4 or later.

## Is CVE-2022-24778 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24778 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24778 and fix it if it is affected.

What it is: CVE-2022-24778 is a high-severity missing authorization vulnerability in Fedoraproject Fedora, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24778 exists.

Affected packages and fixed versions:
- github.com/containerd/imgcrypt (Go): affected all versions; fixed in 1.1.4
- github.com/containerd/imgcrypt (Go): affected all versions; fixed in 1.1.4
- github.com/containerd/imgcrypt (Go): affected all versions; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24778/ (Markdown: https://insights.sbomify.com/CVE-2022-24778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24778
- OSV: https://osv.dev/vulnerability/CVE-2022-24778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24778/
Summaries are generated and may contain mistakes; the official description above is the record.
