CVE-2022-24782 Secure category names leaked via user activity export in Discourse

Medium 4.3 Published Updated

Attackers can leak secure category names via user activity exports in Discourse, exposing sensitive forum structure information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24782?

CVE-2022-24782 is a medium-severity vulnerability in Discourse Discourse, published on 24 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Versions 2.8.2 and prior in the `stable` branch, 2.9.0.beta3 and prior in the `beta` branch, and 2.9.0.beta3 and prior in the `tests-passed` branch are vulnerable to a data leak. Users can request an export of their own activity. Sometimes, due to category settings, they may have category membership for a secure category. The name of this secure category is shown to the user in the export. The same thing occurs when the user's post has been moved to a secure category. A patch for this issue is available in the `main` branch of Discourse's GitHub repository and is anticipated to be part of future releases.

Weakness: CWE-200

Which versions are affected by CVE-2022-24782?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.3

Products include Discourse Discourse.

How do I fix CVE-2022-24782?

Upgrade discourse to 2.8.3 or later.

Is CVE-2022-24782 being exploited?

There is no known exploitation of CVE-2022-24782 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-24782, GHSA-c3cq-w899-f343.

Is CVE-2022-24782 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free