CVE-2022-24783 Sandbox bypass leading to arbitrary code execution in Deno

Critical 10.0 Published Updated

A malicious actor can bypass permission checks in the Deno runtime to execute arbitrary shell code, requiring an immediate upgrade to the patched version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24783?

CVE-2022-24783 is a critical vulnerability in denoland deno, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There is no workaround. All users are recommended to upgrade to 1.20.3 immediately.

Weakness: CWE-863, CWE-269

Which versions are affected by CVE-2022-24783?

2 open source packages ship an affected version, including deno. It affects 1 product.

PackageAffectedFixed in
deno crates.ioFrom 1.18.01.20.3
deno crates.ioFrom 1.18.01.20.3

Products include Deno Deno.

How do I fix CVE-2022-24783?

Upgrade deno to 1.20.3 or later.

Is CVE-2022-24783 being exploited?

There is no known exploitation of CVE-2022-24783 in the wild and no public exploit code.

Sources

Also known as GHSA-838h-jqp6-cf2f.

Is CVE-2022-24783 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free