{"answers":{"affected":"2 open source packages ship an affected version, including deno. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24783 in the wild and no public exploit code.","fix":"Upgrade deno to 1.20.3 or later.","what":"CVE-2022-24783 is a critical vulnerability in denoland deno, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24783 and fix it if it is affected.\n\nWhat it is: CVE-2022-24783 is a critical vulnerability in denoland deno, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24783 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.18.0; fixed in 1.20.3\n- deno (crates.io): affected from 1.18.0; fixed in 1.20.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24783/ (Markdown: https://insights.sbomify.com/CVE-2022-24783/index.md)","id":"CVE-2022-24783","markdown":"https://insights.sbomify.com/CVE-2022-24783/index.md","name":"CVE-2022-24783","record":{"aliases":["GHSA-838h-jqp6-cf2f"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript runtime","requires_auth":"none","summary":"A malicious actor can bypass permission checks in the Deno runtime to execute arbitrary shell code, requiring an immediate upgrade to the patched version.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There is no workaround. All users are recommended to upgrade to 1.20.3 immediately.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Discoverability of user password hash in Statamic CMS","id":"CVE-2022-24784"},"packages":[{"ecosystem":"crates.io","fixed":["1.20.3"],"introduced":["1.18.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-838h-jqp6-cf2f"},{"ecosystem":"crates.io","fixed":["1.20.3"],"introduced":["1.18.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-838h-jqp6-cf2f"}],"prev":{"headline":"Secure category names leaked via user activity export in Discourse","id":"CVE-2022-24782"},"products":["deno"],"published":"2022-03-25","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["denoland"]},"summary":"A malicious actor can bypass permission checks in the Deno runtime to execute arbitrary shell code, requiring an immediate upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2022-24783/"}