# CVE-2022-24783: Sandbox bypass leading to arbitrary code execution in Deno

> A malicious actor can bypass permission checks in the Deno runtime to execute arbitrary shell code, requiring an immediate upgrade to the patched version.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-838h-jqp6-cf2f

## What is CVE-2022-24783?

CVE-2022-24783 is a critical vulnerability in denoland deno, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There is no workaround. All users are recommended to upgrade to 1.20.3 immediately.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-24783?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.18.0 | 1.20.3 |
| `deno` | crates.io | From 1.18.0 | 1.20.3 |

Products: Deno Deno.

## How do I fix CVE-2022-24783?

Upgrade deno to 1.20.3 or later.

## Is CVE-2022-24783 being exploited?

There is no known exploitation of CVE-2022-24783 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)
- [CVE-2023-28446](https://insights.sbomify.com/CVE-2023-28446/): Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24783 and fix it if it is affected.

What it is: CVE-2022-24783 is a critical vulnerability in denoland deno, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24783 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.18.0; fixed in 1.20.3
- deno (crates.io): affected from 1.18.0; fixed in 1.20.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24783/ (Markdown: https://insights.sbomify.com/CVE-2022-24783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24783
- OSV: https://osv.dev/vulnerability/CVE-2022-24783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24783/
Summaries are generated and may contain mistakes; the official description above is the record.
