# CVE-2022-24784: Discoverability of user password hash in Statamic CMS

> Attackers can extract user password hashes character-by-character via API timing attacks if the REST API and users endpoint are enabled.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qcgx-7p5f-hxvr

## What is CVE-2022-24784?

CVE-2022-24784 is a low-severity vulnerability in statamic cms, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Statamic is a Laravel and Git powered CMS. Before versions 3.2.39 and 3.3.2, it is possible to confirm a single character of a user's password hash using a specially crafted regular expression filter in the users endpoint of the REST API. Multiple such requests can eventually uncover the entire hash. The hash is not present in the response, however the presence or absence of a result confirms if the character is in the right position. The API has throttling enabled by default, making this a time intensive task. Both the REST API and the users endpoint need to be enabled, as they are disabled by default. The issue has been fixed in versions 3.2.39 and above, and 3.3.2 and above.

Weakness: CWE-203 (Observable Discrepancy), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24784?

4 open source packages ship an affected version, including statamic/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 3.2.39 |
| `statamic/cms` | Packagist | All versions | 3.2.39 |
| `statamic/cms` | Packagist | From 3.3.0 | 3.3.2 |
| `statamic/cms` | Packagist | From 3.3.0 | 3.3.2 |

Products: Statamic Statamic.

## How do I fix CVE-2022-24784?

Upgrade statamic/cms to a fixed version for your release line: 3.2.39 or 3.3.2.

## Is CVE-2022-24784 being exploited?

There is no known exploitation of CVE-2022-24784 in the wild and no public exploit code.

## Other vulnerabilities in statamic cms

- [CVE-2021-45364](https://insights.sbomify.com/CVE-2021-45364/): Code injection in n/a (critical 9.8)
- [CVE-2026-27593](https://insights.sbomify.com/CVE-2026-27593/): Statamic is vulnerable to account takeover via password reset link injection (critical 9.3)
- [CVE-2026-27939](https://insights.sbomify.com/CVE-2026-27939/): Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass (high 8.8)
- [CVE-2023-48217](https://insights.sbomify.com/CVE-2023-48217/): Remote code execution via form uploads in statamic/cms (high 8.8)
- [CVE-2017-11422](https://insights.sbomify.com/CVE-2017-11422/): Statamic framework Incorrect Permission Assignment (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24784 and fix it if it is affected.

What it is: CVE-2022-24784 is a low-severity vulnerability in statamic cms, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24784 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 3.2.39
- statamic/cms (Packagist): affected all versions; fixed in 3.2.39
- statamic/cms (Packagist): affected from 3.3.0; fixed in 3.3.2
- statamic/cms (Packagist): affected from 3.3.0; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24784/ (Markdown: https://insights.sbomify.com/CVE-2022-24784/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24784
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24784
- OSV: https://osv.dev/vulnerability/CVE-2022-24784

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24784/
Summaries are generated and may contain mistakes; the official description above is the record.
