# CVE-2022-24787: Incorrect Comparison in Vyper


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7vrm-3jc8-5wwm, PYSEC-2022-196

## What is CVE-2022-24787?

CVE-2022-24787 is a high-severity vulnerability in vyperlang vyper, published on 4 Apr 2022. 

### Official description

Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine. In version 0.3.1 and prior, bytestrings can have dirty bytes in them, resulting in the word-for-word comparisons giving incorrect results. Even without dirty nonzero bytes, two bytestrings can compare to equal if one ends with `"\x00"` because there is no comparison of the length. A patch is available and expected to be part of the 0.3.2 release. There are currently no known workarounds.

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2022-24787?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.2 |
| `vyper` | PyPI | All versions | 0.3.2 |
| `vyper` | PyPI | All versions | 0.3.2 |

Products: Vyperlang Vyper.

## How do I fix CVE-2022-24787?

Upgrade vyper to 0.3.2 or later.

## Is CVE-2022-24787 being exploited?

There is no known exploitation of CVE-2022-24787 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24787 and fix it if it is affected.

What it is: CVE-2022-24787 is a high-severity vulnerability in vyperlang vyper, published on 4 Apr 2022. 
Exploitation: There is no known exploitation of CVE-2022-24787 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.2
- vyper (PyPI): affected all versions; fixed in 0.3.2
- vyper (PyPI): affected all versions; fixed in 0.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24787/ (Markdown: https://insights.sbomify.com/CVE-2022-24787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24787
- OSV: https://osv.dev/vulnerability/CVE-2022-24787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24787/
Summaries are generated and may contain mistakes; the official description above is the record.
