{"answers":{"affected":"2 open source packages ship an affected version, including express-openid-connect. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24794 in the wild and no public exploit code.","fix":"Upgrade express-openid-connect to 2.7.2 or later.","what":"CVE-2022-24794 is a high-severity vulnerability in auth0 express-openid-connect, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24794 and fix it if it is affected.\n\nWhat it is: CVE-2022-24794 is a high-severity vulnerability in auth0 express-openid-connect, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24794 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-openid-connect (npm): affected all versions; fixed in 2.7.2\n- express-openid-connect (npm): affected all versions; fixed in 2.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24794/ (Markdown: https://insights.sbomify.com/CVE-2022-24794/index.md)","id":"CVE-2022-24794","markdown":"https://insights.sbomify.com/CVE-2022-24794/index.md","name":"CVE-2022-24794","record":{"aliases":["GHSA-7p99-3798-f85c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js OpenID Connect middleware","requires_auth":"none","summary":"An open redirect vulnerability in express-openid-connect allows attackers to redirect users to malicious sites after login when using catch-all routes.","user_interaction":"not_required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"express_openid_connect","vendor":"auth0"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Express OpenID Connect is an Express JS middleware implementing sign on for Express web apps using OpenID Connect. Users of the `requiresAuth` middleware, either directly or through the default `authRequired` option, are vulnerable to an Open Redirect when the middleware is applied to a catch all route. If all routes under `example.com` are protected with the `requiresAuth` middleware, a visit to `http://example.com//google.com` will be redirected to `google.com` after login because the original url reported by the Express framework is not properly sanitized. This vulnerability affects versions prior to 2.7.2. Users are advised to upgrade. There are no known workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect in express-openid-connect","id":"CVE-2022-24794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Buffer Overflow and Integer Overflow in yajl-ruby","id":"CVE-2022-24795"},"packages":[{"ecosystem":"npm","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"express-openid-connect","purl":null,"source":"GHSA-7p99-3798-f85c"},{"ecosystem":"npm","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"express-openid-connect","purl":"pkg:npm/express-openid-connect","source":"GHSA-7p99-3798-f85c"}],"prev":{"headline":"Potential heap buffer overflow when parsing DNS packets in PJSIP","id":"CVE-2022-24793"},"products":["express-openid-connect"],"published":"2022-03-31","related":[{"cvss_score":4.6,"headline":"Session fixation in express-openid-connect","id":"CVE-2021-41246","kev_date_added":null,"published":"2021-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["auth0"]},"summary":"An open redirect vulnerability in express-openid-connect allows attackers to redirect users to malicious sites after login when using catch-all routes.","url":"https://insights.sbomify.com/CVE-2022-24794/"}