# CVE-2022-24794: Open Redirect in express-openid-connect

> An open redirect vulnerability in express-openid-connect allows attackers to redirect users to malicious sites after login when using catch-all routes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7p99-3798-f85c

## What is CVE-2022-24794?

CVE-2022-24794 is a high-severity vulnerability in auth0 express-openid-connect, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Express OpenID Connect is an Express JS middleware implementing sign on for Express web apps using OpenID Connect. Users of the `requiresAuth` middleware, either directly or through the default `authRequired` option, are vulnerable to an Open Redirect when the middleware is applied to a catch all route. If all routes under `example.com` are protected with the `requiresAuth` middleware, a visit to `http://example.com//google.com` will be redirected to `google.com` after login because the original url reported by the Express framework is not properly sanitized. This vulnerability affects versions prior to 2.7.2. Users are advised to upgrade. There are no known workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-24794?

2 open source packages ship an affected version, including express-openid-connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-openid-connect` | npm | All versions | 2.7.2 |
| `express-openid-connect` | npm | All versions | 2.7.2 |

Products: Auth0 Express Openid Connect.

## How do I fix CVE-2022-24794?

Upgrade express-openid-connect to 2.7.2 or later.

## Is CVE-2022-24794 being exploited?

There is no known exploitation of CVE-2022-24794 in the wild and no public exploit code.

## Other vulnerabilities in auth0 express-openid-connect

- [CVE-2021-41246](https://insights.sbomify.com/CVE-2021-41246/): Session fixation in express-openid-connect (medium 4.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24794 and fix it if it is affected.

What it is: CVE-2022-24794 is a high-severity vulnerability in auth0 express-openid-connect, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24794 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-openid-connect (npm): affected all versions; fixed in 2.7.2
- express-openid-connect (npm): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24794/ (Markdown: https://insights.sbomify.com/CVE-2022-24794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24794
- OSV: https://osv.dev/vulnerability/CVE-2022-24794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24794/
Summaries are generated and may contain mistakes; the official description above is the record.
