# CVE-2022-24798: Insufficient password hash filtering in some IRRd queries and exports

> Attackers can retrieve password hashes from authoritative IRRd instances, potentially leading to unauthorized modification of routing registry objects.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-cqxx-66wh-8pjw, PYSEC-2022-178

## What is CVE-2022-24798?

CVE-2022-24798 is a high-severity vulnerability in irrdnet irrd, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Internet Routing Registry daemon version 4 is an IRR database server, processing IRR objects in the RPSL format. IRRd did not always filter password hashes in query responses relating to `mntner` objects and database exports. This may have allowed adversaries to retrieve some of these hashes, perform a brute-force search for the clear-text passphrase, and use these to make unauthorised changes to affected IRR objects. This issue only affected instances that process password hashes, which means it is limited to IRRd instances that serve authoritative databases. IRRd instances operating solely as mirrors of other IRR databases are not affected. This has been fixed in IRRd 4.2.3 and the main branch. Versions in the 4.1.x series never were affected. Users of the 4.2.x series are strongly recommended to upgrade. There are no known workarounds for this issue.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2022-24798?

3 open source packages ship an affected version, including irrd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `irrd` | PyPI | From 4.2.0 | 4.2.3 |
| `irrd` | PyPI | From 4.2.0 | 4.2.3 |
| `irrd` | PyPI | From 4.2.0 | 4.2.3 |

Products: Internet Routing Registry Daemon Project Internet Routing Registry Daemon.

## How do I fix CVE-2022-24798?

Upgrade irrd to 4.2.3 or later.

## Is CVE-2022-24798 being exploited?

There is no known exploitation of CVE-2022-24798 in the wild and no public exploit code.

## Other vulnerabilities in irrdnet irrd

- [CVE-2026-28681](https://insights.sbomify.com/CVE-2026-28681/): IRRd: web UI host header injection allows password reset poisoning via attacker-controlled email links (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24798 and fix it if it is affected.

What it is: CVE-2022-24798 is a high-severity vulnerability in irrdnet irrd, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24798 in the wild and no public exploit code.

Affected packages and fixed versions:
- irrd (PyPI): affected from 4.2.0; fixed in 4.2.3
- irrd (PyPI): affected from 4.2.0; fixed in 4.2.3
- irrd (PyPI): affected from 4.2.0; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24798/ (Markdown: https://insights.sbomify.com/CVE-2022-24798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24798
- OSV: https://osv.dev/vulnerability/CVE-2022-24798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24798/
Summaries are generated and may contain mistakes; the official description above is the record.
